summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYe Jingchen2017-10-25 00:52:55 +0800
committerYe Jingchen2017-10-25 00:52:55 +0800
commit7ef2c280986ad8daf91d12690e75ddeee1ab332b (patch)
tree36a77993aef3b3b5609a7a2c5cf97c39292904a8
downloadaur-7ef2c280986ad8daf91d12690e75ddeee1ab332b.tar.gz
initial commit, v0.2.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore33
-rw-r--r--PKGBUILD20
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8762cefb57b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-sarasa-gothic
+ pkgdesc = A Chinese & Japanese programming font based on Iosevka and Source Han Sans
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/be5invis/Sarasa-Gothic
+ arch = any
+ license = BSD
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/be5invis/Sarasa-Gothic/releases/download/v0.2.1/sarasa-gothic-0.2.1.7z
+ source = https://github.com/be5invis/Sarasa-Gothic/raw/master/LICENSE
+ sha256sums = b502a60095451cd64ad258ebffe1f18631806cd6c80f1cae6dd1cc92c5544b33
+ sha256sums = SKIP
+
+pkgname = ttf-sarasa-gothic
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6d7a52bcd30a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,33 @@
+
+# Created by https://www.gitignore.io/api/vim,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Vim ###
+# swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-v][a-z]
+[._]sw[a-p]
+# session
+Session.vim
+# temporary
+.netrwhist
+*~
+# auto-generated tag files
+tags
+
+# End of https://www.gitignore.io/api/vim,archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a92be9c2f406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Ye Jingchen <ye.jingchen@gmail.com>
+
+pkgname=ttf-sarasa-gothic
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A Chinese & Japanese programming font based on Iosevka and Source Han Sans"
+arch=('any')
+url="https://github.com/be5invis/Sarasa-Gothic"
+license=('BSD')
+depends=('fontconfig' 'xorg-font-utils')
+source=("https://github.com/be5invis/Sarasa-Gothic/releases/download/v$pkgver/sarasa-gothic-$pkgver.7z"
+ "https://github.com/be5invis/Sarasa-Gothic/raw/master/LICENSE")
+sha256sums=('b502a60095451cd64ad258ebffe1f18631806cd6c80f1cae6dd1cc92c5544b33'
+ 'SKIP')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/TTC"
+ install -m644 "$srcdir/sarasa/"*.ttc "$pkgdir/usr/share/fonts/TTC"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}