summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYe Jingchen2019-10-18 09:34:50 +0800
committerYe Jingchen2019-10-18 09:36:46 +0800
commitf986ea5ebb12e3f8c4542aa69e0269104577d36e (patch)
treefa7e79bb8526de19857e0c8068f0d8e4ce7fd07d
parentde24d828265c37fa9c2e9c032edad26aa833ef20 (diff)
downloadaur-f986ea5ebb12e3f8c4542aa69e0269104577d36e.tar.gz
fix LICENSE file, change pkgdesc
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6ea7ab94331..c3eb574dfa94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = ttf-sarasa-gothic
- pkgdesc = A Chinese & Japanese programming font based on Iosevka and Source Han Sans (TTC)
+ pkgdesc = A CJK programming font based on Iosevka and Source Han Sans. (TTC)
pkgver = 0.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/be5invis/Sarasa-Gothic
arch = any
license = custom:SIL Open Font License v1.1
+ makedepends = curl
depends = fontconfig
depends = xorg-font-utils
source = https://github.com/be5invis/Sarasa-Gothic/releases/download/v0.10.0/sarasa-gothic-ttc-0.10.0.7z
- source = https://raw.githubusercontent.com/be5invis/Sarasa-Gothic/master/LICENSE
sha256sums = 2a8cad733d706b4f1677f91a1d9e97434c00583b662823692358edc90762eabc
- sha256sums = 07e26208b78894948573d001a0133a8d071e161eba6ae65e2ab521fef311a429
pkgname = ttf-sarasa-gothic
diff --git a/.gitignore b/.gitignore
index 6d7a52bcd30a..cda17969b207 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+*.7z
# Created by https://www.gitignore.io/api/vim,archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
index c0924d7d2dff..1d52a965f319 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,20 @@
pkgname=ttf-sarasa-gothic
pkgver=0.10.0
-pkgrel=1
-pkgdesc="A Chinese & Japanese programming font based on Iosevka and Source Han Sans (TTC)"
+pkgrel=2
+pkgdesc="A CJK programming font based on Iosevka and Source Han Sans. (TTC)"
arch=('any')
url="https://github.com/be5invis/Sarasa-Gothic"
license=('custom:SIL Open Font License v1.1')
depends=('fontconfig' 'xorg-font-utils')
-source=("https://github.com/be5invis/Sarasa-Gothic/releases/download/v$pkgver/sarasa-gothic-ttc-$pkgver.7z"
- 'https://raw.githubusercontent.com/be5invis/Sarasa-Gothic/master/LICENSE')
-sha256sums=('2a8cad733d706b4f1677f91a1d9e97434c00583b662823692358edc90762eabc'
- '07e26208b78894948573d001a0133a8d071e161eba6ae65e2ab521fef311a429')
+makedepends=('curl')
+source=("https://github.com/be5invis/Sarasa-Gothic/releases/download/v$pkgver/sarasa-gothic-ttc-$pkgver.7z")
+sha256sums=('2a8cad733d706b4f1677f91a1d9e97434c00583b662823692358edc90762eabc')
+
+prepare() {
+ cd "$srcdir"
+ curl -O 'https://raw.githubusercontent.com/be5invis/Sarasa-Gothic/master/LICENSE'
+}
package() {
install -d "$pkgdir/usr/share/fonts/${pkgname:4}"