summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwuhang20032023-09-08 12:08:12 +0800
committerwuhang20032023-09-08 12:08:12 +0800
commitf725fd5f24cf5df149f853aa3e2f324e38f5b508 (patch)
tree00e54a32822a00018baceaae15372fe549da5678
downloadaur-f725fd5f24cf5df149f853aa3e2f324e38f5b508.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f64ab603e7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-sarasa-gothic-nerd-fonts
+ pkgdesc = Nerd fonts patched Sarasa Gothic font. (TTC)
+ pkgver = 0.41.9_0
+ pkgrel = 1
+ url = https://github.com/jonz94/Sarasa-Gothic-Nerd-Fonts
+ arch = any
+ license = OFL
+ provides = ttf-sarasa-gothic-nerd-fonts
+ source = https://github.com/jonz94/ttc-sarasa-gothic-nerd-fonts/releases/download/v0.41.9-0/sarasa-nerd-font-ttc.zip
+ source = LICENSE-0.41.9-0::https://raw.githubusercontent.com/jonz94/Sarasa-Gothic-Nerd-Fonts/v0.41.9-0/LICENSE
+ sha512sums = c9c4d186f702cf6d2abaff990966c6750a4b7ce603292ba011fc635de8c1f34fa01e9d8ede6340df870a36ed3cf55f844778daad12d2853e937c2fb24b065c04
+ sha512sums = 81709acc66bb7c2de2635c9b6e043f35126228d1f2a8dc6acd93245061177e136be08a7f7aa314731bc95c5fb8c9841b78d9129810650f9a9f590753ae1c8484
+
+pkgname = ttf-sarasa-gothic-nerd-fonts
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..313eac7e06ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: wuhang2003 <i@zwh.moe>
+
+pkgname=ttf-sarasa-gothic-nerd-fonts
+pkgver=0.41.9_0
+pkgrel=1
+pkgdesc="Nerd fonts patched Sarasa Gothic font. (TTC)"
+arch=('any')
+url="https://github.com/jonz94/Sarasa-Gothic-Nerd-Fonts"
+license=('OFL')
+provides=('ttf-sarasa-gothic-nerd-fonts')
+source=("https://github.com/jonz94/ttc-sarasa-gothic-nerd-fonts/releases/download/v${pkgver//_/-}/sarasa-nerd-font-ttc.zip"
+ "LICENSE-${pkgver//_/-}::https://raw.githubusercontent.com/jonz94/Sarasa-Gothic-Nerd-Fonts/v${pkgver//_/-}/LICENSE")
+sha512sums=('c9c4d186f702cf6d2abaff990966c6750a4b7ce603292ba011fc635de8c1f34fa01e9d8ede6340df870a36ed3cf55f844778daad12d2853e937c2fb24b065c04'
+ '81709acc66bb7c2de2635c9b6e043f35126228d1f2a8dc6acd93245061177e136be08a7f7aa314731bc95c5fb8c9841b78d9129810650f9a9f590753ae1c8484')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/${pkgname:4}"
+ install -m644 *.ttc "$pkgdir/usr/share/fonts/${pkgname:4}"
+ install -Dm644 "LICENSE-${pkgver//_/-}" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}