summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmeGa2016-05-22 13:37:16 -0500
committerOmeGa2016-05-22 13:37:16 -0500
commit98c58effbd0c96dd4e34f1b2fac70a4f31b1d4b9 (patch)
tree668498501b0dbdda98efdad378ef3037dd4b90a2
downloadaur-98c58effbd0c96dd4e34f1b2fac70a4f31b1d4b9.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE53
-rw-r--r--PKGBUILD23
-rw-r--r--ttf.install16
4 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45043fc45e05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun May 22 18:34:15 UTC 2016
+pkgbase = ttf-sbl-greek
+ pkgdesc = SBL Greek biblical font.
+ pkgver = 1.00_Build010
+ pkgrel = 1
+ url = https://www.sbl-site.org/educational/BiblicalFonts_SBLGreek.aspx
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.sbl-site.org/Fonts/SBL_grk.ttf
+ source = LICENSE
+ sha1sums = 12c99111cae4e7958b0645297cf6c53587a96dce
+ sha1sums = 9d5a3931ce42dce53f245e9a8a0803a7c2c98751
+
+pkgname = ttf-sbl-greek
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..26648c22909c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,53 @@
+SBL Font End User License Agreement
+
+This license agreement explains the rights and responsibilities that you accept when you install
+the SBL Hebrew font on your computer. Please take a few minutes to review this.
+
+1. The digitally encoded machine readable font software for producing the typefaces licensed to
+you is the property of Tiro Typeworks. It is licensed to you for use under the terms of this end
+user license agreement. If you have any questions about this license agreement, or have a need to
+use the font software in a way not covered by this agreement, please write to license@tiro.com.
+
+2. You may use this font software free of charge for all non-commercial purposes. If you wish to
+obtain a license for commercial use of this font software, please contact the Society of Biblical
+Literature at sblfonts@sbl-site.org, or write to license@tiro.com. Fees for commercial licenses
+are at the individual discretion of the Society of Biblical Literature and Tiro Typeworks.
+
+3. You may redistribute this font software free of charge as long as the software is unmodified,
+all copyright and trademark notices are intact, and the font contains or is accompanied by a copy
+of this license agreement. You may not charge any fee for the distribution of this font software or
+alter the terms of this license agreement.
+
+4. You may decompile and modify this font software for non-commercial and personal use by
+you as an individual or internal use within your organisation. Tiro Typeworks maintains
+copyright to all derivative fonts in any format. You may not delete, edit or add to copyright,
+trademark or license information in the font. You may not change the embedding bit. You may
+not redistribute any modified version of the font software, either free of charge or for a fee.
+Copies of modified fonts should be submitted to Tiro Typeworks (license@tiro.com) and to the
+Society of Biblical Literature (sblexec@sbl-site.org), along with any relevant documentation.
+Tiro Typeworks reserves the right to incorporate any such changes into its own fonts.
+
+5. You may embed the font software in non-commercial electronic documents, including but not
+limited to web pages and e-books. Font embedding must respect the embedding bit in the font,
+which must not be changed. The embedding bit for this font software is set to 'Editable
+Embedding', meaning that documents containing this font software may be viewed, printed and
+edited, but the embedded font may not be installed on the recipient user's system.
+
+6. All other rights are reserved by Tiro Typeworks, except as otherwise designated in contract
+between Tiro Typeworks and the Society of Biblical Literature.
+
+7. Neither Tiro Typeworks not the Society of Biblical Literature warrant the performance or
+results you may obtain by using this font software. Excepting any warranty, condition,
+representation or term that cannot or may not be excluded or limited by law applicable to you in
+your jurisdiction, Tiro Typeworks and the Society of Biblical Literature make no warranties,
+conditions, representations, or terms (express or implied whether by statute, common law,
+custom, usage or otherwise) as to any matter including, without limitation, noninfringement of
+third party rights, merchantability, integration, satisfactory quality, or fitness for any
+particular purpose.
+
+8. Neither Tiro Typeworks nor the Society of Biblical Literature accept any liability for injury,
+death, financial loss or damage to person or property (including computer hardware, software or
+data) resulting from the use of this font software.
+
+9. The act of installing this font software on any computer system constitutes acceptance of the
+terms of this license agreement, without exception.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25492c349d81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
+
+pkgname=ttf-sbl-greek
+pkgver=1.00_Build010
+pkgrel=1
+pkgdesc="SBL Greek biblical font."
+arch=('any')
+url="https://www.sbl-site.org/educational/BiblicalFonts_SBLGreek.aspx"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=("http://www.sbl-site.org/Fonts/SBL_grk.ttf"
+ "LICENSE")
+sha1sums=('12c99111cae4e7958b0645297cf6c53587a96dce'
+ '9d5a3931ce42dce53f245e9a8a0803a7c2c98751')
+
+package() {
+ cd "$srcdir"
+ install -Dm644 SBL_grk.ttf "$pkgdir/usr/share/fonts/TTF/SBL_grk.ttf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..905d8c8c7702
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+