summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdiel Mittmann2015-06-30 12:08:05 -0300
committerAdiel Mittmann2015-06-30 12:08:05 -0300
commit3fb5c5bafef74acb8105d682a9eca23c6890cf2c (patch)
tree8962b3c5545e65fef5ad0d2df6c498ae94e1f80b
downloadaur-3fb5c5bafef74acb8105d682a9eca23c6890cf2c.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD18
-rw-r--r--ttf-siddhanta.install14
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90d80d02b235
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-siddhanta
+ pkgdesc = A beautiful font for the Devanagari script.
+ pkgver = 20140319
+ pkgrel = 1
+ url = https://sites.google.com/site/bayaryn/
+ install = ttf-siddhanta.install
+ arch = any
+ license = cc-by-nc-nd-3.0
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://sites.google.com/site/bayaryn/siddhanta.ttf
+ source = LICENSE
+ md5sums = 2a5926f0248a38ec0f11c9835898bcc8
+ md5sums = afc2a94432491e466a41371fbd4791e3
+
+pkgname = ttf-siddhanta
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d4d2ea4b0060
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,3 @@
+"Siddhanta font software (including font variations and Vaidika IME) is
+published under Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported
+License."
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5386d41a049
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Adiel Mittmann <adiel@inf.ufsc.br>
+pkgname=ttf-siddhanta
+pkgver=20140319
+pkgrel=1
+pkgdesc="A beautiful font for the Devanagari script."
+arch=('any')
+url="https://sites.google.com/site/bayaryn/"
+license=('cc-by-nc-nd-3.0')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=$pkgname.install
+source=('https://sites.google.com/site/bayaryn/siddhanta.ttf' LICENSE)
+md5sums=('2a5926f0248a38ec0f11c9835898bcc8'
+ 'afc2a94432491e466a41371fbd4791e3')
+
+package() {
+ install -m 644 -D $srcdir/siddhanta.ttf $pkgdir/usr/share/fonts/TTF/siddhanta.ttf
+ install -m 644 -D $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ttf-siddhanta.install b/ttf-siddhanta.install
new file mode 100644
index 000000000000..7f3ce84218d3
--- /dev/null
+++ b/ttf-siddhanta.install
@@ -0,0 +1,14 @@
+post_install()
+{
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade()
+{
+ post_install
+}
+