summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-15 11:58:02 +0300
committerCaleb Maclennan2020-02-15 11:58:02 +0300
commit745316e9b44a8f95b3306c14bcce71f808c6789f (patch)
tree296022203a1b3e0bb2abe11014a29a61b6d7a9b2
parent90a672ae1a6876205a56ec3fe36bcaa35621ec23 (diff)
downloadaur-745316e9b44a8f95b3306c14bcce71f808c6789f.tar.gz
Update SIL font packaging so it doesn't conflict with meta package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e938216a225..4ea1e595f11d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ttf-sil-abyssinica
- pkgdesc = OpenType calligraphic font for Ethiopic languages from SIL
+ pkgdesc = Ethiopic script font following calligraphic traditions
pkgver = 2.000
- pkgrel = 1
- url = https://software.sil.org/abyssinica/
+ pkgrel = 2
+ url = https://software.sil.org/abyssinica
arch = any
license = custom:OFL
depends = fontconfig
diff --git a/PKGBUILD b/PKGBUILD
index f34e40f88c2e..5a7d81527a57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-pkgname=ttf-sil-abyssinica
+_pkgname=abyssinica
+pkgname=ttf-sil-$_pkgname
_fname=AbyssinicaSIL
pkgver=2.000
-pkgrel=1
-pkgdesc='OpenType calligraphic font for Ethiopic languages from SIL'
+pkgrel=2
+pkgdesc='Ethiopic script font following calligraphic traditions'
arch=('any')
-url='https://software.sil.org/abyssinica/'
+url="https://software.sil.org/$_pkgname"
license=('custom:OFL')
depends=('fontconfig' 'xorg-font-utils')
-source=("http://software.sil.org/downloads/r/abyssinica/$_fname-$pkgver.zip")
+source=("http://software.sil.org/downloads/r/$_pkgname/$_fname-$pkgver.zip")
sha256sums=('274204a53b30f64cca662d78c7199e3c0325ea95ad4109886b47af734c92d0f9')
package() {
cd "$_fname-$pkgver"
find -type f -name "$_fname*.ttf" -execdir \
- install -Dm644 {} "$pkgdir"/usr/share/fonts/TTF/{} \;
- install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname"/LICENSE
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
}