summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-15 15:19:57 +0300
committerCaleb Maclennan2020-02-15 15:19:57 +0300
commitaad9a4498b15f08742a8df00d84f10104054c3eb (patch)
treee364c8e74014bffb74067491dfdaba2f1b922248
downloadaur-aad9a4498b15f08742a8df00d84f10104054c3eb.tar.gz
Initial packaging
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1eb42eae158
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-sil-alkalami
+ pkgdesc = Unicode font for Arabic-based writing systems in the Kango region of Nigeria and Niger
+ pkgver = 1.200
+ pkgrel = 1
+ url = https://software.sil.org/alkalami
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://software.sil.org/downloads/r/alkalami/Alkalami-1.200.zip
+ sha256sums = f294789b09d1aaaa56f70b198ab842b88803ae649ce3e4e74df8e9f1ac4662d5
+
+pkgname = ttf-sil-alkalami
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..898f5f65711c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=alkalami
+pkgname=ttf-sil-$_pkgname
+_fname=${_pkgname^}
+pkgver=1.200
+pkgrel=1
+pkgdesc='Unicode font for Arabic-based writing systems in the Kango region of Nigeria and Niger'
+arch=('any')
+url="https://software.sil.org/$_pkgname"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://software.sil.org/downloads/r/$_pkgname/$_fname-$pkgver.zip")
+sha256sums=('f294789b09d1aaaa56f70b198ab842b88803ae649ce3e4e74df8e9f1ac4662d5')
+
+package() {
+ cd "$_fname-$pkgver"
+ find -type f -iname "$_fname*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}