summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-15 13:18:08 +0300
committerCaleb Maclennan2020-02-15 13:18:08 +0300
commit0907b63daa1a7dcec9935feb62c96cb99cef2713 (patch)
treeebb2854c4c36335f66879ba2733b2884f248618c
downloadaur-0907b63daa1a7dcec9935feb62c96cb99cef2713.tar.gz
Initial independent packaging, previously in ttf-sil-fonts
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65ca84141f6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-sil-galatia
+ pkgdesc = Unicode font to support Biblical Polytonic Greek
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://software.sil.org/galatia
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://software.sil.org/downloads/r/galatia/GalatiaSIL-2.1.zip
+ sha256sums = 0d0a34646a18267c5147ee01448268098ebb00c4563eb6e9260037f2d171aa92
+
+pkgname = ttf-sil-galatia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cac85c76aebf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=galatia
+pkgname=ttf-sil-$_pkgname
+_fname=${_pkgname^}SIL
+pkgver=2.1
+pkgrel=1
+pkgdesc='Unicode font to support Biblical Polytonic Greek'
+arch=('any')
+url="https://software.sil.org/$_pkgname"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://software.sil.org/downloads/r/$_pkgname/$_fname-$pkgver.zip")
+sha256sums=('0d0a34646a18267c5147ee01448268098ebb00c4563eb6e9260037f2d171aa92')
+
+package() {
+ cd "${_fname/atia}${pkgver/.}"
+ find -type f -iname "${_fname/atia}*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}