summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2015-07-07 11:25:30 +0300
committerCaleb Maclennan2015-07-07 11:25:30 +0300
commit2a7fd535134eda414f0867df9340b4030fb7120d (patch)
tree3d885c2a2e1fd84e2f1104e4310279fc032bd9e5
downloadaur-2a7fd535134eda414f0867df9340b4030fb7120d.tar.gz
add package as adopted
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
-rw-r--r--ttf.install20
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02e4069069a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ttf-sil-lateef
+ pkgdesc = OpenType Arabic font from SIL
+ pkgver = 1
+ pkgrel = 4
+ url = http://scripts.sil.org/ArabicFonts
+ install = ttf.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = ttf-sil-arabic
+ conflicts = ttf-sil-fonts
+ source = lateef.zip::http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=lateef_opentype&filename=LateefRegOT_ttf.zip
+ source = LICENSE::http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=OFL_plaintext&filename=OFL.txt
+ md5sums = c59adf1aed6bdc4163edba707756acd0
+ md5sums = 6ed93967ff0dc6dd9c8d31c17f817a06
+
+pkgname = ttf-sil-lateef
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13018a6fc6c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: bslackr <brendan at vastactive dot com>
+# Contributor: Firmicus <firmicus āt gmx dōt net>
+
+pkgname=ttf-sil-lateef
+pkgver=1
+pkgrel=4
+pkgdesc="OpenType Arabic font from SIL"
+arch=('i686' 'x86_64')
+url="http://scripts.sil.org/ArabicFonts"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('ttf-sil-arabic' 'ttf-sil-fonts')
+install=ttf.install
+source=('lateef.zip::http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=lateef_opentype&filename=LateefRegOT_ttf.zip' 'LICENSE::http://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=OFL_plaintext&filename=OFL.txt')
+md5sums=('c59adf1aed6bdc4163edba707756acd0'
+ '6ed93967ff0dc6dd9c8d31c17f817a06')
+
+build() {
+ install -Dm644 ${srcdir}/LateefRegOT.ttf ${pkgdir}/usr/share/fonts/TTF/lateef.ttf
+ install -Dm644 "${srcdir}/LICENSE" ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..7a325abf4eb9
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache /usr/share/fonts/TTF
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*