summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-15 13:45:22 +0300
committerCaleb Maclennan2020-02-15 13:45:22 +0300
commitecdcb496aacf80992e8111a9381c0038acdb07c5 (patch)
treeedc4e197b9083731052272704e3f99b6a4e939e8
downloadaur-ecdcb496aacf80992e8111a9381c0038acdb07c5.tar.gz
Initial independent packaging, previously in ttf-sil-fonts
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a39e7ddab87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-sil-mondulkiri
+ pkgdesc = Khmer Mondulkiri, Busra, Oureang, and Ratanakiri fonts for the Khmer script
+ pkgver = 7.100
+ pkgrel = 1
+ url = https://software.sil.org/mondulkiri
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://software.sil.org/downloads/r/mondulkiri/Mondulkiri-7.100.zip
+ source = http://software.sil.org/downloads/r/mondulkiri/Mondulkiri-5.300.zip
+ sha256sums = c2e5dc08f4835be9a0da5cf9dcf92105aff973e47fc31e075e8bc44bec632c85
+ sha256sums = 6de8d3c40d0bff74fb83d76a0d4579e4c0d0ceb204d2adcebf99a355267835fe
+
+pkgname = ttf-sil-mondulkiri
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e328be91e2e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=mondulkiri
+pkgname=ttf-sil-$_pkgname
+_fname=${_pkgname^}
+pkgver=7.100
+_pkgver=5.300
+pkgrel=1
+pkgdesc='Khmer Mondulkiri, Busra, Oureang, and Ratanakiri fonts for the Khmer script'
+arch=('any')
+url="https://software.sil.org/$_pkgname"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://software.sil.org/downloads/r/$_pkgname/$_fname-$pkgver.zip"
+ "http://software.sil.org/downloads/r/$_pkgname/$_fname-$_pkgver.zip")
+sha256sums=('c2e5dc08f4835be9a0da5cf9dcf92105aff973e47fc31e075e8bc44bec632c85'
+ '6de8d3c40d0bff74fb83d76a0d4579e4c0d0ceb204d2adcebf99a355267835fe')
+
+package() {
+ cd "$_fname-$pkgver"
+ find -type f -iname "*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ cd "../$_fname-$_pkgver"
+ find -type f -iname "*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+}