summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-15 15:31:51 +0300
committerCaleb Maclennan2020-02-15 15:31:51 +0300
commit438f2916e56782f132632a3a62b08c128c39ae10 (patch)
treeee8d0093b0053399489085f391a430f613d1ea67
downloadaur-438f2916e56782f132632a3a62b08c128c39ae10.tar.gz
Initial packaging
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae947179f0d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-sil-tagmukay
+ pkgdesc = A Shifinagh font that supports the Tawallammat dialect of Tamajaq
+ pkgver = 2.000
+ pkgrel = 1
+ url = https://software.sil.org/tagmukay
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://software.sil.org/downloads/r/tagmukay/Tagmukay-2.000.zip
+ sha256sums = f657adf6c91e75f81d53bb4f305df80656f2eee7013d349493883e4bcb6edbcd
+
+pkgname = ttf-sil-tagmukay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71b959a82e88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=tagmukay
+pkgname=ttf-sil-$_pkgname
+_fname=${_pkgname^}
+pkgver=2.000
+pkgrel=1
+pkgdesc='A Shifinagh font that supports the Tawallammat dialect of Tamajaq'
+arch=('any')
+url="https://software.sil.org/$_pkgname"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://software.sil.org/downloads/r/$_pkgname/$_fname-$pkgver.zip")
+sha256sums=('f657adf6c91e75f81d53bb4f305df80656f2eee7013d349493883e4bcb6edbcd')
+
+package() {
+ cd "$_fname-$pkgver"
+ find -type f -iname "$_fname*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}