summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-05-11 22:49:17 -0400
committerErik Dubois2017-05-11 22:49:17 -0400
commit4efba5d1d078f1c5bb4f1cb60ae354336614abb0 (patch)
tree1fb04bf933e37d3403a66e10c6182e04d0a02618
downloadaur-4efba5d1d078f1c5bb4f1cb60ae354336614abb0.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--45-sorts-mill-goudy.conf12
-rw-r--r--90-tt-sorts-mill-goudy.conf26
-rw-r--r--PKGBUILD37
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ab1ce0ec481
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri May 12 02:49:13 UTC 2017
+pkgbase = ttf-sorts-mill-goudy-ibx
+ pkgdesc = A modern revival of Goudy Oldstyle and Italic. TrueType version.
+ pkgver = 3.1
+ pkgrel = 9
+ url = http://crudfactory.com/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = MIT
+ depends = fontconfig
+ conflicts = ttf-sortsmillgoudy
+ conflicts = otf-sorts-mill-goudy-ibx
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sortsmill/goudy-3.1.zip
+ source = 45-sorts-mill-goudy.conf
+ source = 90-tt-sorts-mill-goudy.conf
+ sha1sums = 6a4f2878c1dbd5a995351e555c02a66cc8decb74
+ sha1sums = 91ec08c2e735908fce86bf89380d82fa2c6bd666
+ sha1sums = dfa5cb778431cd331b1539326eb7072acbc1dc55
+
+pkgname = ttf-sorts-mill-goudy-ibx
+
diff --git a/45-sorts-mill-goudy.conf b/45-sorts-mill-goudy.conf
new file mode 100644
index 000000000000..8a10db679932
--- /dev/null
+++ b/45-sorts-mill-goudy.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Sorts Mill Goudy</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-sorts-mill-goudy.conf b/90-tt-sorts-mill-goudy.conf
new file mode 100644
index 000000000000..d4de3b79cd9a
--- /dev/null
+++ b/90-tt-sorts-mill-goudy.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Sorts Mill Goudy TT</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e8a1af5a0e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=ttf-sorts-mill-goudy-ibx
+pkgver=3.1
+pkgrel=9
+depends=('fontconfig')
+pkgdesc="A modern revival of Goudy Oldstyle and Italic. TrueType version."
+url="http://crudfactory.com/"
+arch=('any')
+groups=('infinality-bundle-fonts-extra')
+conflicts=('ttf-sortsmillgoudy' 'otf-sorts-mill-goudy-ibx')
+license=('MIT')
+source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/sortsmill/goudy-3.1.zip"
+ 45-sorts-mill-goudy.conf
+ 90-tt-sorts-mill-goudy.conf)
+sha1sums=('6a4f2878c1dbd5a995351e555c02a66cc8decb74'
+ '91ec08c2e735908fce86bf89380d82fa2c6bd666'
+ 'dfa5cb778431cd331b1539326eb7072acbc1dc55')
+
+package(){
+ install -m755 -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ install -m644 COPYING "${pkgdir}"/usr/share/licenses/"${pkgname}"
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ install -m644 45-sorts-mill-goudy.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-sorts-mill-goudy.conf
+ install -m644 90-tt-sorts-mill-goudy.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-sorts-mill-goudy.conf
+
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-sorts-mill-goudy.conf .
+ ln -s ../conf.avail/90-tt-sorts-mill-goudy.conf .
+}