summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-05-11 22:33:15 -0400
committerErik Dubois2017-05-11 22:33:15 -0400
commite95af93740c05eaca3e7950fbff7ce39c9b82fa4 (patch)
treeccfe3a68e8bbed1f46f1cb5096a1754b77dab57e
downloadaur-e95af93740c05eaca3e7950fbff7ce39c9b82fa4.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--45-source-code-pro.conf12
-rw-r--r--90-tt-source-code-pro.conf26
-rw-r--r--PKGBUILD44
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..385a0c530083
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri May 12 02:33:12 UTC 2017
+pkgbase = ttf-source-code-pro-ibx
+ pkgdesc = A set of OpenType fonts designed for user interfaces. TrueType version.
+ pkgver = 2.030ro+1.050it
+ pkgrel = 1
+ url = http://www.adobe.com/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = custom:OFL
+ depends = fontconfig
+ conflicts = adobe-source-code-pro-fonts
+ conflicts = otf-source-code-pro
+ conflicts = ttf-source-code-pro
+ conflicts = t1-source-code-pro-ibx
+ conflicts = otf-source-code-pro-ibx
+ source = 2.030R-ro-1.050R-it.tar.gz::https://github.com/adobe-fonts/source-code-pro/archive/2.030R-ro/1.050R-it.tar.gz
+ source = 45-source-code-pro.conf
+ source = 90-tt-source-code-pro.conf
+ sha1sums = fb8601043ec55da1b1cfd27a0843ea5eb14c6cad
+ sha1sums = d20feb494116f95e4a35ad40f625a94f9a3bbcb2
+ sha1sums = ae4fa14a8aa927e325a8bfd7c0f8db29eefb00ab
+
+pkgname = ttf-source-code-pro-ibx
+
diff --git a/45-source-code-pro.conf b/45-source-code-pro.conf
new file mode 100644
index 000000000000..ebf204a8e3cb
--- /dev/null
+++ b/45-source-code-pro.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Source Code Pro</family>
+ <default>
+ <family>monospace</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-source-code-pro.conf b/90-tt-source-code-pro.conf
new file mode 100644
index 000000000000..899d7102486d
--- /dev/null
+++ b/90-tt-source-code-pro.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Source Code Pro</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc9453da2514
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=ttf-source-code-pro-ibx
+pkgver=2.030ro+1.050it
+_relver=2.030R-ro/1.050R-it
+_tarver=${_relver//\//-}
+pkgrel=1
+depends=('fontconfig')
+pkgdesc="A set of OpenType fonts designed for user interfaces. TrueType version."
+url="http://www.adobe.com/"
+arch=('any')
+license=('custom:OFL')
+conflicts=('adobe-source-code-pro-fonts' 'otf-source-code-pro' 'ttf-source-code-pro' 't1-source-code-pro-ibx' 'otf-source-code-pro-ibx')
+groups=('infinality-bundle-fonts-extra')
+source=("${_tarver}.tar.gz::https://github.com/adobe-fonts/source-code-pro/archive/${_relver}.tar.gz"
+ 45-source-code-pro.conf
+ 90-tt-source-code-pro.conf)
+sha1sums=('fb8601043ec55da1b1cfd27a0843ea5eb14c6cad'
+ 'd20feb494116f95e4a35ad40f625a94f9a3bbcb2'
+ 'ae4fa14a8aa927e325a8bfd7c0f8db29eefb00ab')
+
+package(){
+ cd "source-code-pro-$_tarver"
+
+ install -m755 -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ install -m644 LICENSE.txt \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 TTF/*.ttf \
+ "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ cd "${srcdir}"
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ install -m644 45-source-code-pro.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-source-code-pro.conf
+ install -m644 90-tt-source-code-pro.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-source-code-pro.conf
+
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-source-code-pro.conf .
+ ln -s ../conf.avail/90-tt-source-code-pro.conf .
+}