summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-07-01 12:37:21 +0100
committerJonathon Fernyhough2017-07-01 12:37:21 +0100
commit64aead959f6b20ba562e24ec3d1f658797a66874 (patch)
treeecddaf7d5460cc71e0b2e737a11e3f72fa4c5a9e
downloadaur-64aead959f6b20ba562e24ec3d1f658797a66874.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..994f74525564
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ttf-soutane
+ pkgdesc = Soutane TTF typeface
+ pkgver = 20150207
+ pkgrel = 1
+ url = http://www.webpagefonts.com/
+ arch = any
+ license = custom
+ source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Regular.ttf
+ source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold.ttf
+ source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Italic.ttf
+ source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold%20Italic.ttf
+ source = http://www.webpagepublicity.com/free-fonts/s/SoutaneBlack%20Regular.ttf
+ sha256sums = d28114931256495a45b96fc3a833bbba2169c84e7543a0d16367424e4b1faff3
+ sha256sums = ec923856a2f5c88ea667d5ac0d7c90cd60ffce538efe39182e13abd96b2de613
+ sha256sums = 44dc858666f5df9d726869413ea34f0298b8eedf5dd125fc394a7e0e612293d8
+ sha256sums = 0a4de3907dbda0eb487e9152d03d9aa69c1915620f666bd33ae3a0c2b1f1ae92
+ sha256sums = fc0f2e8c6ab17f510dcab260c2b8af041743646cb87689f155ff88222222ea38
+
+pkgname = ttf-soutane
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58395f4b4cbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
+
+pkgname=ttf-soutane
+pkgver=20150207
+pkgrel=1
+pkgdesc="Soutane TTF typeface"
+arch=(any)
+url="http://www.webpagefonts.com/"
+license=(custom)
+source=("http://www.webpagepublicity.com/free-fonts/s/Soutane%20Regular.ttf"
+ "http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold.ttf"
+ "http://www.webpagepublicity.com/free-fonts/s/Soutane%20Italic.ttf"
+ "http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold%20Italic.ttf"
+ "http://www.webpagepublicity.com/free-fonts/s/SoutaneBlack%20Regular.ttf")
+sha256sums=('d28114931256495a45b96fc3a833bbba2169c84e7543a0d16367424e4b1faff3'
+ 'ec923856a2f5c88ea667d5ac0d7c90cd60ffce538efe39182e13abd96b2de613'
+ '44dc858666f5df9d726869413ea34f0298b8eedf5dd125fc394a7e0e612293d8'
+ '0a4de3907dbda0eb487e9152d03d9aa69c1915620f666bd33ae3a0c2b1f1ae92'
+ 'fc0f2e8c6ab17f510dcab260c2b8af041743646cb87689f155ff88222222ea38')
+
+prepare() {
+ cd "${srcdir}"
+ for font in *ttf; do
+ mv -fv "${font}" "$(echo "${font}" | sed -e 's/%20/-/g' - )"
+ done
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}"/usr/share/fonts/soutane
+ install -m644 Soutane*.ttf "${pkgdir}"/usr/share/fonts/soutane
+
+ # TODO find license
+ # install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}