summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-07-30 13:17:15 +0100
committerJonathon Fernyhough2017-07-30 13:17:15 +0100
commit6b86c5af3c57c9ee7c48ca6b40e38df71ef07e49 (patch)
treef7d5ec13b8e5e64b8eebe1cdbc2bd50920be442a
parent96b1542d24f6831a20cd6441e27dd67ee5bbf98b (diff)
downloadaur-6b86c5af3c57c9ee7c48ca6b40e38df71ef07e49.tar.gz
Remove unnecessary prepare(). Install to TTF directory.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 994f74525564..392a53fb7037 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ttf-soutane
pkgdesc = Soutane TTF typeface
pkgver = 20150207
- pkgrel = 1
+ pkgrel = 2
url = http://www.webpagefonts.com/
arch = any
license = custom
- source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Regular.ttf
- source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold.ttf
- source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Italic.ttf
- source = http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold%20Italic.ttf
- source = http://www.webpagepublicity.com/free-fonts/s/SoutaneBlack%20Regular.ttf
+ source = Soutane-Regular.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Regular.ttf
+ source = Soutane-Bold.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold.ttf
+ source = Soutane-Italic.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Italic.ttf
+ source = Soutane-Bold-Italic.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold%20Italic.ttf
+ source = SoutaneBlack-Regular.ttf::http://www.webpagepublicity.com/free-fonts/s/SoutaneBlack%20Regular.ttf
sha256sums = d28114931256495a45b96fc3a833bbba2169c84e7543a0d16367424e4b1faff3
sha256sums = ec923856a2f5c88ea667d5ac0d7c90cd60ffce538efe39182e13abd96b2de613
sha256sums = 44dc858666f5df9d726869413ea34f0298b8eedf5dd125fc394a7e0e612293d8
diff --git a/PKGBUILD b/PKGBUILD
index 5505fa099d27..85e24b4be630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,26 @@
pkgname=ttf-soutane
_pkgname=soutane
pkgver=20150207
-pkgrel=1
+pkgrel=2
pkgdesc="Soutane TTF typeface"
arch=(any)
url="http://www.webpagefonts.com/"
license=(custom)
-source=("http://www.webpagepublicity.com/free-fonts/s/Soutane%20Regular.ttf"
- "http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold.ttf"
- "http://www.webpagepublicity.com/free-fonts/s/Soutane%20Italic.ttf"
- "http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold%20Italic.ttf"
- "http://www.webpagepublicity.com/free-fonts/s/SoutaneBlack%20Regular.ttf")
+source=("Soutane-Regular.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Regular.ttf"
+ "Soutane-Bold.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold.ttf"
+ "Soutane-Italic.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Italic.ttf"
+ "Soutane-Bold-Italic.ttf::http://www.webpagepublicity.com/free-fonts/s/Soutane%20Bold%20Italic.ttf"
+ "SoutaneBlack-Regular.ttf::http://www.webpagepublicity.com/free-fonts/s/SoutaneBlack%20Regular.ttf")
sha256sums=('d28114931256495a45b96fc3a833bbba2169c84e7543a0d16367424e4b1faff3'
'ec923856a2f5c88ea667d5ac0d7c90cd60ffce538efe39182e13abd96b2de613'
'44dc858666f5df9d726869413ea34f0298b8eedf5dd125fc394a7e0e612293d8'
'0a4de3907dbda0eb487e9152d03d9aa69c1915620f666bd33ae3a0c2b1f1ae92'
'fc0f2e8c6ab17f510dcab260c2b8af041743646cb87689f155ff88222222ea38')
-prepare() {
- cd "${srcdir}"
- mkdir out
- for font in *ttf; do
- mv -fv "${font}" out/"$(echo "${font}" | sed -e 's/%20/-/g' - )"
- done
- mv out/* ./
- rmdir out
-}
-
package() {
cd "${srcdir}"
- mkdir -p "${pkgdir}"/usr/share/fonts/${_pkgname}
- install -m644 ./*.ttf "${pkgdir}"/usr/share/fonts/${_pkgname}
+ mkdir -p "${pkgdir}"/usr/share/fonts/TTF/${_pkgname}
+ install -m644 ./*.ttf "${pkgdir}"/usr/share/fonts/TTF/${_pkgname}
# TODO find license
# install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE