summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2015-08-11 18:03:35 +0300
committerkyak2015-08-11 18:03:35 +0300
commit2c26badee846cdf6fefe8818f2857fcb9dcc9655 (patch)
tree401396c2e22e3e94b44392dc837d6eb7beacb539
downloadaur-2c26badee846cdf6fefe8818f2857fcb9dcc9655.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--ttf.install15
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fed2bb3c853
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ttf-tahoma
+ pkgdesc = Tahoma and Tahoma Bold fonts from the Wine project
+ pkgver = 1.7.27
+ pkgrel = 1
+ epoch = 1
+ url = http://www.winehq.org/
+ install = ttf.install
+ arch = any
+ license = LGPL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = tahoma-1.7.27.ttf::http://source.winehq.org/source/fonts/tahoma.ttf?!v=wine-1.7.27&_raw=1
+ source = tahomabd-1.7.27.ttf::http://source.winehq.org/source/fonts/tahomabd.ttf?!v=wine-1.7.27&_raw=1
+ sha256sums = 8385eb7b3930798411953b8789245ae47e9a9e8480f7f37ecb8da1d895363954
+ sha256sums = c29342ba99a04f983193756f01eb6de946fd4d33ba0bb7061aff11e70871b6f2
+
+pkgname = ttf-tahoma
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd927377165c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: TDY <tdy@archlinux.info>
+# Contributor: Thomas Laroche <tho.laroche @t gmail.com>
+# Contributor: Thayer Williams <thayer@archlinux.org>
+# Contributor: dale <dale@archlinux.org>
+
+pkgname=ttf-tahoma
+pkgver=1.7.27
+pkgrel=1
+epoch=1
+pkgdesc="Tahoma and Tahoma Bold fonts from the Wine project"
+arch=('any')
+url="http://www.winehq.org/"
+license=('LGPL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=ttf.install
+source=(tahoma-$pkgver.ttf::"http://source.winehq.org/source/fonts/tahoma.ttf?!v=wine-$pkgver&_raw=1"
+ tahomabd-$pkgver.ttf::"http://source.winehq.org/source/fonts/tahomabd.ttf?!v=wine-$pkgver&_raw=1")
+sha256sums=('8385eb7b3930798411953b8789245ae47e9a9e8480f7f37ecb8da1d895363954'
+ 'c29342ba99a04f983193756f01eb6de946fd4d33ba0bb7061aff11e70871b6f2')
+
+package() {
+ install -Dm644 tahoma-$pkgver.ttf "$pkgdir/usr/share/fonts/TTF/tahoma.ttf"
+ install -Dm644 tahomabd-$pkgver.ttf "$pkgdir/usr/share/fonts/TTF/tahomabd.ttf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..33b7d65490db
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}