summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxNNism2017-07-07 18:09:26 +0200
committerxNNism2017-07-07 18:09:26 +0200
commit3cb9d9b2bac910d281965b7f134b9f6ac0c2d276 (patch)
tree66f02ab439e21c20d9c84b11ead998691a7726b6
downloadaur-3cb9d9b2bac910d281965b7f134b9f6ac0c2d276.tar.gz
initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
-rw-r--r--tannenberg.bold.ttfbin0 -> 13160 bytes
-rw-r--r--tannenberg.contour.ttfbin0 -> 27572 bytes
-rw-r--r--tannenberg.shadow.ttfbin0 -> 24096 bytes
-rw-r--r--ttf-tannenberg.install15
6 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f78565b336c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ttf-tannenberg
+ pkgdesc = Old WW2 era font used for creating historical documents and artwork
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.dafont.com/tannenberg-fett.font
+ install = ttf-tannenberg.install
+ arch = any
+ license = SIL Open Font License v1.1
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-mkfontdir
+ depends = xorg-mkfontscale
+ source = https://github.com/Blackbyte-Inc/ttf-tannenberg/raw/master/tannenberg.bold.ttf
+ source = https://github.com/Blackbyte-Inc/ttf-tannenberg/raw/master/tannenberg.contour.ttf
+ source = https://github.com/Blackbyte-Inc/ttf-tannenberg/raw/master/tannenberg.shadow.ttf
+ sha256sums = c4b1a086515ef1b94453523c6133eedeabbd809113dbdddd5e72aae8b99b36cc
+ sha256sums = 020118f0a1f5965a76c7fd5939652b4dd436d495392a59734a58edabe8d2907f
+ sha256sums = ace761c42abe229bf8e0f8234cf17bedbe6f317ec499bcdfd9fd217e0bf78227
+
+pkgname = ttf-tannenberg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c78b756dea6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: xNN <xNNism@gmail.com>
+
+pkgname=ttf-tannenberg
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Old WW2 era font used for creating historical documents and artwork"
+arch=('any')
+url="http://www.dafont.com/tannenberg-fett.font"
+license=('SIL Open Font License v1.1')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-mkfontdir' 'xorg-mkfontscale')
+install=ttf-tannenberg.install
+source=("https://github.com/Blackbyte-Inc/ttf-tannenberg/raw/master/tannenberg.bold.ttf"
+ "https://github.com/Blackbyte-Inc/ttf-tannenberg/raw/master/tannenberg.contour.ttf"
+ "https://github.com/Blackbyte-Inc/ttf-tannenberg/raw/master/tannenberg.shadow.ttf")
+sha256sums=('c4b1a086515ef1b94453523c6133eedeabbd809113dbdddd5e72aae8b99b36cc'
+ '020118f0a1f5965a76c7fd5939652b4dd436d495392a59734a58edabe8d2907f'
+ 'ace761c42abe229bf8e0f8234cf17bedbe6f317ec499bcdfd9fd217e0bf78227')
+
+package() {
+ install -dm 755 "${pkgdir}"/usr/share/fonts/TTF
+ install -m 644 *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+} \ No newline at end of file
diff --git a/tannenberg.bold.ttf b/tannenberg.bold.ttf
new file mode 100644
index 000000000000..9e7e2e09472c
--- /dev/null
+++ b/tannenberg.bold.ttf
Binary files differ
diff --git a/tannenberg.contour.ttf b/tannenberg.contour.ttf
new file mode 100644
index 000000000000..a445017e2d50
--- /dev/null
+++ b/tannenberg.contour.ttf
Binary files differ
diff --git a/tannenberg.shadow.ttf b/tannenberg.shadow.ttf
new file mode 100644
index 000000000000..dabd5e5a3143
--- /dev/null
+++ b/tannenberg.shadow.ttf
Binary files differ
diff --git a/ttf-tannenberg.install b/ttf-tannenberg.install
new file mode 100644
index 000000000000..67445cf458e1
--- /dev/null
+++ b/ttf-tannenberg.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}