summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Peters2023-05-29 15:11:49 -0400
committerStephan Peters2023-05-29 15:11:49 -0400
commitfb4b1d7314815bef19758372752af2765f3c239c (patch)
tree65ee10c0bf3a84352709d0a61a9559d7f73eac0f
parente81848aceb7ea870b386c77389a7c70dcab9dbe5 (diff)
downloadaur-fb4b1d7314815bef19758372752af2765f3c239c.tar.gz
Final
-rw-r--r--PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 041d9a53a19e..6e6f1d8025d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Riedler <dev@riedler.wien>
# Contributor: xNN <xNNism@gmail.com>
-fontname=tannenberg
+_fontname=tannenberg
_include_webfonts=false
# true to include webfonts with ttf or type1 installation.
-# explicitly installing the webfonts-$fontname package overrides this value to true.
+# explicitly installing the webfonts-$_fontname package overrides this value to true.
_webfontdir=$HOME/www/fonts
# Directory for woff and woff2 files.
@@ -15,22 +15,22 @@ _webfontdir=$HOME/www/fonts
_pfmdir=/usr/share/fonts/type1/
# Directory for postscript type 1 .pfm and .pfb files.
-# Change to install in an alternate location, example: "/psfonts/$fontname/"
+# Change to install in an alternate location, example: "/psfonts/$_fontname/"
_afmdir=/usr/share/fonts/type1/
# Directory for postscript type 1 .afm files.
-# Change to install in an alternate location, example: "/psfonts/$fontname/afm"
+# Change to install in an alternate location, example: "/psfonts/$_fontname/afm"
-# Postscript Type 1 fonts are only installed if explicitly installing the type1-$fontname package.
+# Postscript Type 1 fonts are only installed if explicitly installing the type1-$_fontname package.
# This is a largely obsolete format, and would only be needeed for specialized applications.
# Only the original files from TypeOasis are installed, this package does not include TeX .tfm files.
# TeX .tfm files can be generated from the included Type 1 files with a utility.
-#pkgname=("ttf-$fontname" "type1-$fontname" "webfonts-$fontname")
-pkgname=("ttf-$fontname") # use to install a single package locally.
-licensefile="ffc.html"
+#pkgname=("ttf-$_fontname" "type1-$_fontname" "webfonts-$_fontname")
+pkgname=("ttf-$_fontname") # use to install a single package locally.
+_licensefile="ffc.html"
pkgver=1.002
-pkgrel=2.0
+pkgrel=2
# name=""
pkgdesc="Tannenberg is a Fraktur-family blackletter typeface, developed in Germany between 1933 and 1935 digitized by Dieter Steffmann."
arch=(any)
@@ -48,17 +48,17 @@ sha256sums=("e5261b8ccac3aa18a1f8715f329708164a45816913e86c0da8f8e69aa1fe8a5d")
# and generated webfonts using https://www.fontsquirrel.com/tools/webfont-generator .
prepare(){
- bsdtar xvf "$fontname-font.tar.gz"
+ bsdtar xvf "$_fontname-font.tar.gz"
}
install_license(){
- if [ ! -f "/usr/share/licenses/$fontname-font/$licensefile" ] ; then
- install -Dm644 -t "$pkgdir"/"usr/share/licenses"/"$fontname-font" "$srcdir"/"usr/share/licenses"/"$fontname-font"/*.*
+ if [ ! -f "/usr/share/licenses/$_fontname-font/$_licensefile" ] ; then
+ install -Dm644 -t "$pkgdir"/"usr/share/licenses"/"$_fontname-font" "$srcdir"/"usr/share/licenses"/"$_fontname-font"/*.*
fi
}
install_fonts(){
- #install -Dm644 -t "$pkgdir"/usr/share/fonts/"$fontname" "$srcdir"/usr/share/fonts/"${1^^}"/*."$1"
+ #install -Dm644 -t "$pkgdir"/usr/share/fonts/"$_fontname" "$srcdir"/usr/share/fonts/"${1^^}"/*."$1"
install -Dm644 -t "$pkgdir"/usr/share/fonts/"${1^^}" "$srcdir"/usr/share/fonts/"${1^^}"/*."$1"
}
@@ -70,21 +70,21 @@ install_postscript(){
install_webfonts(){
if [ "$_include_webfonts" = true ] ; then
mkdir -p "$pkgdir"/"$_webfontdir"
- if [ ! -f "$_webfontdir"/"$fontname.bold.woff" ] ; then
+ if [ ! -f "$_webfontdir"/"$_fontname.bold.woff" ] ; then
install -Dm644 -t "$pkgdir"/"$_webfontdir" "$srcdir"/www/fonts/*.woff
fi
- if [ ! -f "$_webfontdir/$fontname.bold.woff2" ] ; then
+ if [ ! -f "$_webfontdir/$_fontname.bold.woff2" ] ; then
install -Dm644 -t "$pkgdir"/"$_webfontdir" "$srcdir"/www/fonts/*.woff2
echo -e "\e[32mWebfonts will be installed in ${_webfontdir}.\e[0m"
fi
- if [ ! -f "$_webfontdir/$fontname-stylesheet.css" ] ; then
- install -Dm644 -t "$pkgdir"/"$_webfontdir" "$srcdir"/www/fonts/"$fontname-stylesheet.css"
+ if [ ! -f "$_webfontdir/$_fontname-stylesheet.css" ] ; then
+ install -Dm644 -t "$pkgdir"/"$_webfontdir" "$srcdir"/www/fonts/"$_fontname-stylesheet.css"
fi
fi
}
package_ttf-tannenberg() {
- #conflicts+=("otf-$fontname")
+ #conflicts+=("otf-$_fontname")
install_license
install_fonts ttf
install_webfonts