summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:23:10 -0400
committerKyle Keen2015-06-13 00:23:10 -0400
commit88142d5d7a365335d0e031a05498f863ff2dc1e4 (patch)
tree84ae3e39c769d2e68932c433b016f1fe5945de96
downloadaur-88142d5d7a365335d0e031a05498f863ff2dc1e4.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO17
-rw-r--r--COPYING31
-rw-r--r--PKGBUILD33
-rw-r--r--ttf.install15
5 files changed, 111 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c0185ee68648
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-tengwar-annatar
+ pkgdesc = The Tengwar Annatar ttf font family. (Tolkein Elvish)
+ pkgver = 1.20
+ pkgrel = 1
+ url = http://tengwar.art.pl/tengwar/fonty.php
+ install = ttf.install
+ arch = any
+ license = custom: tengwar-annatar
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://tengwar.art.pl/tengwar/zip/tngan120.zip
+ source = COPYING
+
+pkgname = ttf-tengwar-annatar
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7605e3dbea6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-tengwar-annatar
+ pkgdesc = The Tengwar Annatar ttf font family. (Tolkein Elvish)
+ pkgver = 1.20
+ pkgrel = 1
+ url = http://tengwar.art.pl/tengwar/fonty.php
+ install = ttf.install
+ arch = any
+ license = custom: tengwar-annatar
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://tengwar.art.pl/tengwar/zip/tngan120.zip
+ source = COPYING
+ md5sums = 8833d945ed5e512f136d27fad6c985d5
+ md5sums = aaf041d42dd102899bf03407fd1dc8a0
+
+pkgname = ttf-tengwar-annatar
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..2a313a25f7af
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,31 @@
+Tengwar Annatar is distributed under the following license:
+
+----------------------------------------------------------------
+
+The Tengwar Annatar type family, henceforth referred to as font,
+is the property of the creator, Johan Winge, copyright (c) 2004-
+2005. It is distributed as freeware, meaning that you may down-
+load it, free of charge, and use it in any non-commercial publi-
+cation or product. The following limitations apply:
+
+Even though the scenario is highly unlikely, I take no responsi-
+bility what so ever should the use or attempted use of this font
+cause any damage to your computer system. All use of this font
+is at your own risk.
+
+You may redistribute this font under the following terms: That
+all files, without exceptions, in the original distribution are
+included in unmodified form, and that no fee is charged, (except
+at most to cover private personal expenses, e.g. the cost of a
+single floppy disk).
+
+In the case of commercial use, this font may be used in a com-
+mercial project of yours, as long as I am provided, at your ex-
+pense, with a free copy of the final product. This also applies,
+but is not limited, to share- or freeware compilations.
+
+Please note that for you to use J. R. R. Tolkien's tengwar
+script in a commercial production you may have to have permis-
+sion from the Tolkien Estate.
+
+----------------------------------------------------------------
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5847a07b728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
+
+pkgname=ttf-tengwar-annatar
+pkgver=1.20
+pkgrel=1
+pkgdesc="The Tengwar Annatar ttf font family. (Tolkein Elvish)"
+arch=(any)
+#url="http://home.student.uu.se/j/jowi4905/fonts/annatar.html"
+url="http://tengwar.art.pl/tengwar/fonty.php"
+license=('custom: tengwar-annatar')
+depends=(fontconfig xorg-font-utils)
+install=ttf.install
+#source=('http://home.student.uu.se/j/jowi4905/fonts/tngan120.zip'
+source=('http://tengwar.art.pl/tengwar/zip/tngan120.zip'
+ 'COPYING')
+
+md5sums=('8833d945ed5e512f136d27fad6c985d5'
+ 'aaf041d42dd102899bf03407fd1dc8a0')
+
+package() {
+ cd "$srcdir"
+
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/ttf-tengwar-annatar/license"
+
+ install -Dm644 readme.txt "$pkgdir/usr/share/tengwar-annatar/README"
+ install -Dm644 tngandoc.pdf "$pkgdir/usr/share/tengwar-annatar/README.pdf"
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..7dde94b45180
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}