summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Room2023-05-12 14:34:43 +0100
committerAdrian Room2023-05-12 14:34:43 +0100
commit2fcf6b12376ea26c758d95a06d298069f52731ab (patch)
tree6272ae6344b60ce2ee635315ffa88a63158c161c
downloadaur-2fcf6b12376ea26c758d95a06d298069f52731ab.tar.gz
initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ac4708b7468
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ttf-tengwar-formal-csur
+ pkgdesc = A tengwar (Tolkien's elvish) font using the CSUR character mapping
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://freetengwar.sourceforge.net/formal.html
+ arch = any
+ license = gpl3
+ source = ttf-tengwar-formal-csur-1.1.zip::http://sourceforge.net/projects/freetengwar/files/TengwarFont/TengwarFormalCSUR11.zip/download
+ sha256sums = 924c282f7f967ecf6ca81003d95d4355dcccda9cf3fb7afdc746cb9d8f8250c7
+
+pkgname = ttf-tengwar-formal-csur
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1b16d93bca5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Adrian Room <ingolemo@gmail.com>
+
+pkgname=ttf-tengwar-formal-csur
+pkgver=1.1
+pkgrel=1
+pkgdesc="A conversion of Tengwar Formal to the CSUR character mapping"
+license=("custom:ofl")
+arch=("any")
+url="https://freetengwar.sourceforge.net/formal.html"
+source=(
+ "$pkgname-$pkgver.zip::http://sourceforge.net/projects/freetengwar/files/TengwarFont/TengwarFormalCSUR11.zip/download"
+)
+sha256sums=('924c282f7f967ecf6ca81003d95d4355dcccda9cf3fb7afdc746cb9d8f8250c7')
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -Dm644 -t "${pkgdir}/usr/share/fonts/TTF/" TengwarFormalCSUR11/TengwarFormalCSUR.ttf
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" TengwarFormalCSUR11/OFL.txt
+ install -Dm644 -t "${pkgdir}/usr/share/${pkgname}/README" TengwarFormalCSUR11/FontLog.txt
+}
+