summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2024-01-29 10:50:22 +0100
committerÓscar García Amor2024-01-29 10:50:22 +0100
commit90b87cc2e39949cc695d3f4e19d0ca47f68d4f64 (patch)
tree320416b52561eaca5e39c9811b06b6b1132df649
downloadaur-90b87cc2e39949cc695d3f4e19d0ca47f68d4f64.tar.gz
Initial upload: ttf-topaz-unicode 1-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55e01d26ec82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ttf-topaz-unicode
+ pkgdesc = A version of the Amiga 500 "Topaz" font updated for the 21st century
+ pkgver = 1
+ pkgrel = 1
+ url = https://gitlab.com/Screwtapello/topaz-unicode
+ arch = any
+ license = LicenseRef-Custom-ISC
+ source = ttf-topaz-unicode-1.zip::https://gitlab.com/Screwtapello/topaz-unicode/-/jobs/6036905109/artifacts/download
+ source = https://gitlab.com/Screwtapello/topaz-unicode/-/raw/main/LICENSE
+ b2sums = 7cee7f0651045c63400f9f59d83f5721024d44532c5eedaa594233179e599d618067456655b06e81f8966a57e73f3f8fc7c832fbec756ecf25d12b8c816a2dbd
+ b2sums = 76e5489cc124d7e93634926e28a88337ebc631dc25c126aff06477bc030fac751abd5d7199b7e9ed600ec0b6510e01ec8540b20a51a747202e288b3888c5de9b
+
+pkgname = ttf-topaz-unicode
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be2322b8e606
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Oscar Garcia Amor <ogarcia@connectical.com>
+
+pkgname=ttf-topaz-unicode
+pkgver=1
+pkgrel=1
+pkgdesc='A version of the Amiga 500 "Topaz" font updated for the 21st century'
+arch=('any')
+url='https://gitlab.com/Screwtapello/topaz-unicode'
+license=('LicenseRef-Custom-ISC')
+source=("${pkgname}-${pkgver}.zip::https://gitlab.com/Screwtapello/topaz-unicode/-/jobs/6036905109/artifacts/download"
+ "https://gitlab.com/Screwtapello/topaz-unicode/-/raw/main/LICENSE")
+b2sums=('7cee7f0651045c63400f9f59d83f5721024d44532c5eedaa594233179e599d618067456655b06e81f8966a57e73f3f8fc7c832fbec756ecf25d12b8c816a2dbd'
+ '76e5489cc124d7e93634926e28a88337ebc631dc25c126aff06477bc030fac751abd5d7199b7e9ed600ec0b6510e01ec8540b20a51a747202e288b3888c5de9b')
+
+package() {
+ install -dm755 ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}