summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMa Jiehong2015-06-09 22:17:30 +0200
committerMa Jiehong2015-06-09 22:17:30 +0200
commit4e21c982c884c1212e003d6449348585a799900a (patch)
tree5233858641168d9c8cc4e8dd091229e19b05fa9d
downloadaur-4e21c982c884c1212e003d6449348585a799900a.tar.gz
Import ttf-tw to AUR 4
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--ttf.install15
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c13a500963bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 9 20:17:03 UTC 2015
+pkgbase = ttf-tw
+ pkgdesc = Set of KAI and SONG fonts from the Ministry of Education of Taiwan. These fonts follow all the official recommendations and their shapes are calligraphically correct.
+ pkgver = 20130103
+ pkgrel = 1
+ epoch = 1
+ url = http://www.moe.gov.tw/
+ install = ttf.install
+ arch = any
+ license = CC-BY-ND 3.0
+ depends = fontconfig
+ depends = xorg-font-utils
+ depends = git
+ source = git+https://github.com/Jiehong/TW-fonts.git
+ source = ttf.install
+ sha512sums = SKIP
+ sha512sums = 6dde1db4c4204d89ee7d388b6f5fe972202adf4d294d18d709c94074278b8cdce129fc35ce55c62428487e4cc8df03a4c374df2e63b8406214a8a68661a1b114
+
+pkgname = ttf-tw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..796490ada783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ma Jiehong <email at majiehong.com>
+pkgname=ttf-tw
+epoch=1
+pkgver=20130103
+pkgrel=1
+pkgdesc="Set of KAI and SONG fonts from the Ministry of Education of Taiwan. These fonts follow all the official recommendations and their shapes are calligraphically correct."
+arch=('any')
+url="http://www.moe.gov.tw/"
+license=('CC-BY-ND 3.0')
+depends=('fontconfig' 'xorg-font-utils' 'git')
+conflicts=()
+install=ttf.install
+source=(git+https://github.com/Jiehong/TW-fonts.git
+ ttf.install)
+sha512sums=('SKIP'
+'6dde1db4c4204d89ee7d388b6f5fe972202adf4d294d18d709c94074278b8cdce129fc35ce55c62428487e4cc8df03a4c374df2e63b8406214a8a68661a1b114')
+
+pkgver()
+{
+cd "$srcdir/TW-fonts"
+git show --no-patch --date=short --format=format:%cd | tr -d -
+}
+
+package()
+{
+cd "$srcdir"
+install -Dm644 TW-fonts/edukai-3.ttf "$pkgdir/usr/share/fonts/TTF/edukai-3.ttf"
+install -Dm644 TW-fonts/eduSong_Unicode.ttf "$pkgdir/usr/share/fonts/TTF/eduSong_Unicode.ttf"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..aa7f72b87e1f
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n '==> Rebuilding font cache…'
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo 'done'
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}