summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttila Fidan2024-05-11 11:18:37 +0000
committerAttila Fidan2024-05-11 11:18:37 +0000
commit26ec039614c598271229236544a4e814a5e2207b (patch)
tree4c6b99a8213269d0066a04b699a72c4eaab08b90
parent22ed497c6f0c9058254b7a0d207b8ec840ce4149 (diff)
downloadaur-26ec039614c598271229236544a4e814a5e2207b.tar.gz
add setuptools's distutils for python 3.12, etc.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD78
2 files changed, 66 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c73e4c29e46..e260b5cb2d7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,30 @@
pkgbase = ttf-twemoji-color-git
- pkgdesc = A color and B&W emoji SVG-in-OpenType font by Twitter with support for ZWJ, skin tone modifiers and country flags (git)
- pkgver = 14.0.2.r0.ge451b5d
+ pkgdesc = Color and B&W SVGinOT builds of Twemoji
+ pkgver = 14.0.2.r2.g80a6926
pkgrel = 1
epoch = 1
- url = https://github.com/eosrei/twemoji-color-font
+ url = https://github.com/13rac1/twemoji-color-font
arch = any
- license = custom:CCPL:by-4.0
+ license = CC-BY-4.0
license = MIT
+ makedepends = fontforge
makedepends = git
makedepends = inkscape
makedepends = imagemagick
+ makedepends = nodejs
makedepends = potrace
makedepends = python-fonttools
- makedepends = fontforge
- makedepends = svgo
- makedepends = nodejs
+ makedepends = python-setuptools
makedepends = python-yaml
- provides = twemoji-color-font
- provides = ttf-twemoji-color
+ makedepends = svgo
provides = emoji-font
- conflicts = twemoji-color-font
+ provides = ttf-twemoji-color
+ provides = twemoji-color-font
conflicts = ttf-twemoji-color
- replaces = twemoji-color-font
- source = git+https://github.com/eosrei/twemoji-color-font.git
+ conflicts = twemoji-color-font
+ source = git+https://github.com/13rac1/twemoji-color-font.git#branch=main
+ source = git+https://github.com/13rac1/scfbuild.git#branch=master
+ b2sums = SKIP
b2sums = SKIP
pkgname = ttf-twemoji-color-git
diff --git a/PKGBUILD b/PKGBUILD
index b04728cbd200..441ce9d9a674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,69 @@
-# Maintainer: AtticFinder65536 <atticventilation-aur at protonmail dot com>
+# Maintainer: Attila Fidan <archlinux-buildsystem@print0.net>
-pkgname=('ttf-twemoji-color-git')
-_gitname=('twemoji-color-font')
-pkgver=14.0.2.r0.ge451b5d
+pkgname=ttf-twemoji-color-git
+_gitname=twemoji-color-font
+pkgver=14.0.2.r2.g80a6926
pkgrel=1
epoch=1
-pkgdesc="A color and B&W emoji SVG-in-OpenType font by Twitter with support for ZWJ, skin tone modifiers and country flags (git)"
-url="https://github.com/eosrei/twemoji-color-font"
-license=('custom:CCPL:by-4.0' 'MIT')
-source=('git+https://github.com/eosrei/twemoji-color-font.git'
- 'git+https://github.com/13rac1/scfbuild.git')
+
+pkgdesc="Color and B&W SVGinOT builds of Twemoji"
+url="https://github.com/13rac1/twemoji-color-font"
+license=(
+ CC-BY-4.0
+ MIT
+)
+arch=(any)
+
+source=(
+ "git+$url.git#branch=main"
+ "git+https://github.com/13rac1/scfbuild.git#branch=master"
+)
b2sums=('SKIP'
- 'SKIP')
-makedepends=('git' 'inkscape' 'imagemagick' 'potrace' 'python-fonttools' 'fontforge' 'svgo' 'nodejs' 'python-yaml')
-arch=('any')
-replaces=('twemoji-color-font')
-provides=('twemoji-color-font' 'ttf-twemoji-color' 'emoji-font')
-conflicts=('twemoji-color-font' 'ttf-twemoji-color')
+ 'SKIP')
+
+makedepends=(
+ fontforge
+ git
+ inkscape
+ imagemagick
+ nodejs
+ potrace
+ python-fonttools
+ python-setuptools
+ python-yaml
+ svgo
+)
+
+provides=(
+ emoji-font
+ ttf-twemoji-color
+ twemoji-color-font
+)
+conflicts=(
+ ttf-twemoji-color
+ twemoji-color-font
+)
pkgver() {
cd "$_gitname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){
- cd "${_gitname}"
- ln -s "${srcdir}"/scfbuild SCFBuild
- sed -i 's/package: regular-package linux-package deb-package macos-package windows-package/package: linux-package/' Makefile
+ cd "$_gitname"
+ rm SCFBuild
+ ln -s "${srcdir}"/scfbuild SCFBuild
+ sed -i 's/package: regular-package linux-package deb-package macos-package windows-package/package: linux-package/' Makefile
}
build(){
- cd "${_gitname}"
- make
+ cd "$_gitname"
+ make
}
package(){
- cd "${_gitname}"/build/TwitterColorEmoji-SVGinOT-Linux-14.0.2
- install -Dm644 TwitterColorEmoji-SVGinOT.ttf -t "$pkgdir"/usr/share/fonts/TTF/
- install -Dm644 LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgname/
- install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname/
+ cd "$_gitname"/build/TwitterColorEmoji-SVGinOT-Linux-14.0.2
+ install -Dm644 TwitterColorEmoji-SVGinOT.ttf -t "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
-