summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtticFinder655362022-05-01 15:23:35 +1000
committerAtticFinder655362022-05-01 15:23:35 +1000
commitb43a517fd671e7196d84b6a31c714b10aa344e1c (patch)
treec17a8e5817ae0e4db1f69cca4e7973959a6583b0
downloadaur-b43a517fd671e7196d84b6a31c714b10aa344e1c.tar.gz
Initial port of package from my personal repository
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD40
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33ace57d949b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ttf-twemoji-color-git
+ pkgdesc = A color and B&W emoji SVG-in-OpenType font by Twitter with support for ZWJ, skin tone modifiers and country flags (git)
+ pkgver = v13.1.0.r2.g3239f32
+ pkgrel = 1
+ url = https://github.com/eosrei/twemoji-color-font
+ arch = any
+ license = custom:CCPL:by-4.0
+ license = MIT
+ makedepends = git
+ makedepends = inkscape
+ makedepends = imagemagick
+ makedepends = potrace
+ makedepends = python-fonttools
+ makedepends = fontforge
+ makedepends = svgo
+ makedepends = nodejs
+ makedepends = python-yaml
+ provides = twemoji-color-font
+ provides = ttf-twemoji-color
+ provides = emoji-font
+ conflicts = twemoji-color-font
+ conflicts = ttf-twemoji-color
+ replaces = twemoji-color-font
+ source = git+https://github.com/eosrei/twemoji-color-font.git
+ b2sums = SKIP
+
+pkgname = ttf-twemoji-color-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4fccb3584d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: AtticFinder65536 <atticventilation-aur at protonmail dot com>
+
+pkgname=('ttf-twemoji-color-git')
+_gitname=('twemoji-color-font')
+pkgver=v13.1.0.r2.g3239f32
+pkgrel=1
+pkgdesc="A color and B&W emoji SVG-in-OpenType font by Twitter with support for ZWJ, skin tone modifiers and country flags (git)"
+url="https://github.com/eosrei/twemoji-color-font"
+license=('custom:CCPL:by-4.0' 'MIT')
+source=('git+https://github.com/eosrei/twemoji-color-font.git')
+b2sums=('SKIP')
+makedepends=('git' 'inkscape' 'imagemagick' 'potrace' 'python-fonttools' 'fontforge' 'svgo' 'nodejs' 'python-yaml')
+arch=('any')
+replaces=('twemoji-color-font')
+provides=('twemoji-color-font' 'ttf-twemoji-color' 'emoji-font')
+conflicts=('twemoji-color-font' 'ttf-twemoji-color')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd "${_gitname}"
+ git clone https://github.com/13rac1/scfbuild.git SCFBuild
+ sed -i 's/package: regular-package linux-package deb-package macos-package windows-package/package: linux-package/' Makefile
+}
+
+build(){
+ cd "${_gitname}"
+ make
+}
+
+package(){
+ cd "${_gitname}"/build/TwitterColorEmoji-SVGinOT-Linux-13.1.0
+ install -Dm644 TwitterColorEmoji-SVGinOT.ttf -t "$pkgdir"/usr/share/fonts/TTF/
+ install -Dm644 LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgname/
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname/
+}
+