summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2017-03-16 12:59:20 -0400
committersolaraquarion2017-03-16 12:59:20 -0400
commit72dc73d99a430837cc8222a21e7982c92cf95ef7 (patch)
tree177a040c7d4f6c1ee67edfa98ed1427bcbe76646
downloadaur-72dc73d99a430837cc8222a21e7982c92cf95ef7.tar.gz
initial import
-rw-r--r--.SRCINFO25
-rw-r--r--45-ubuntu.conf26
-rw-r--r--90-tt-ubuntu.conf71
-rw-r--r--PKGBUILD44
4 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e21a380eb00d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Mar 16 16:59:07 UTC 2017
+pkgbase = ttf-ubuntu-font-family-ib
+ pkgdesc = Ubuntu font family. Part of infinality-bundle-fonts.
+ pkgver = 0.83
+ pkgrel = 3
+ url = http://font.ubuntu.com/
+ arch = any
+ groups = infinality-bundle-fonts
+ license = custom:Ubuntu Font Licence 1.0
+ depends = fontconfig
+ provides = ttf-font
+ provides = ttf-ubuntu-font-family
+ conflicts = ttf-ubuntu-font-family
+ replaces = ttf-ubuntu-font-family
+ replaces = ttf-ubuntu-font-family-ibx
+ source = http://font.ubuntu.com/download/ubuntu-font-family-0.83.zip
+ source = 45-ubuntu.conf
+ source = 90-tt-ubuntu.conf
+ sha1sums = fad7939b33af4ae9ce803b403373ff49bbf1233f
+ sha1sums = 5089359e856cb621d24746f79f64e85e53ce35c8
+ sha1sums = 00de40a3bdfc1d6fefa40e5acf00f54c1dbce7cf
+
+pkgname = ttf-ubuntu-font-family-ib
+
diff --git a/45-ubuntu.conf b/45-ubuntu.conf
new file mode 100644
index 000000000000..d660f28d3d27
--- /dev/null
+++ b/45-ubuntu.conf
@@ -0,0 +1,26 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Ubuntu</family>
+ <default>
+ <family>sans-serif</family>
+ </default>
+ </alias>
+
+ <alias>
+ <family>Ubuntu Condensed</family>
+ <default>
+ <family>sans-serif</family>
+ </default>
+ </alias>
+
+ <alias>
+ <family>Ubuntu Mono</family>
+ <default>
+ <family>monospace</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-ubuntu.conf b/90-tt-ubuntu.conf
new file mode 100644
index 000000000000..9ed867b65cfd
--- /dev/null
+++ b/90-tt-ubuntu.conf
@@ -0,0 +1,71 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <!-- Ubuntu -->
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Ubuntu</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <!-- Ubuntu Condensed -->
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Ubuntu Condensed</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <!-- Ubuntu Mono -->
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Ubuntu Mono</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..083f01f4dbd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 88127 2013-04-12 09:51:38Z mtorromeo $
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: bohoomil <@zoho.com>
+
+pkgname=ttf-ubuntu-font-family-ib
+pkgver=0.83
+pkgrel=3
+pkgdesc="Ubuntu font family. Part of infinality-bundle-fonts."
+arch=('any')
+url="http://font.ubuntu.com/"
+license=('custom:Ubuntu Font Licence 1.0')
+depends=('fontconfig')
+groups=('infinality-bundle-fonts')
+conflicts=('ttf-ubuntu-font-family')
+provides=('ttf-font' 'ttf-ubuntu-font-family')
+replaces=('ttf-ubuntu-font-family' 'ttf-ubuntu-font-family-ibx')
+source=(http://font.ubuntu.com/download/ubuntu-font-family-$pkgver.zip
+ 45-ubuntu.conf
+ 90-tt-ubuntu.conf)
+sha1sums=('fad7939b33af4ae9ce803b403373ff49bbf1233f'
+ '5089359e856cb621d24746f79f64e85e53ce35c8'
+ '00de40a3bdfc1d6fefa40e5acf00f54c1dbce7cf')
+
+package() {
+ cd "ubuntu-font-family-${pkgver}"
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 Ubuntu-{L,R,B,C}*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 UbuntuMono-*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -D -m644 LICENCE.txt \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ cd "${srcdir}"
+ install -D -m644 45-ubuntu.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-ubuntu.conf
+ install -D -m644 90-tt-ubuntu.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-ubuntu.conf
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-ubuntu.conf .
+ ln -s ../conf.avail/90-tt-ubuntu.conf .
+}