summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Christensen2015-06-08 11:24:38 -0600
committerDevin Christensen2015-06-08 11:24:38 -0600
commit9f011d4c42d8850212cf53259ea2c6d804d64416 (patch)
tree2477b35827796d686c2c0e32492cdfe81b7e4130
downloadaur-9f011d4c42d8850212cf53259ea2c6d804d64416.tar.gz
Create package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--ttf-ubuntu-mono-derivative-powerline-git.install15
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7840738d540d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-ubuntu-mono-derivative-powerline-git
+ pkgdesc = Ubuntu Mono derivative Powerline
+ pkgver = r71.39c99c0
+ pkgrel = 1
+ url = https://github.com/powerline/fonts
+ install = ttf-ubuntu-mono-derivative-powerline-git.install
+ arch = any
+ license = custom:Ubuntu Font License, Version 1.0
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = powerline-fonts
+ conflicts = powerline-fonts-git
+ source = git://github.com/powerline/fonts.git
+ md5sums = SKIP
+
+pkgname = ttf-ubuntu-mono-derivative-powerline-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..599153f82a2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=ttf-ubuntu-mono-derivative-powerline-git
+pkgver=r71.39c99c0
+pkgrel=1
+pkgdesc="Ubuntu Mono derivative Powerline"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('custom:Ubuntu Font License, Version 1.0')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(powerline-fonts powerline-fonts-git)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts/UbuntuMono
+ find . -iname '*.ttf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/TTF/{} \;
+ install -Dm644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ttf-ubuntu-mono-derivative-powerline-git.install b/ttf-ubuntu-mono-derivative-powerline-git.install
new file mode 100644
index 000000000000..83322116247a
--- /dev/null
+++ b/ttf-ubuntu-mono-derivative-powerline-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ mkfontscale /usr/share/fonts/TTF > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/TTF > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}