summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoonov2015-06-08 20:15:13 +0900
committernoonov2015-06-08 20:15:13 +0900
commit04a98f0d1b3fddb208bdca48332e25aecdfea4a0 (patch)
treefcf1881121bb848c47621d3cf7f97f1494f61c33
downloadaur-04a98f0d1b3fddb208bdca48332e25aecdfea4a0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--ttf.install20
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ee87a8a0cf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-umeplus
+ pkgdesc = Modified Ume and M+ fonts for Japanese
+ pkgver = 20150115
+ pkgrel = 1
+ url = http://www.geocities.jp/ep3797/modified_fonts_01.html
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://downloads.sourceforge.net/mdk-ut/umeplus-fonts-20150115.tar.lzma
+ md5sums = bac6afe82549015be4b8c91d8401c9db
+ sha256sums = 032952bfe8fe5dceea354005bcac0a8c27116d222a4878fe9701f67cf4571e54
+
+pkgname = ttf-umeplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b58c7d04dfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jorge Mokross <mokross@gmail.com>
+# Contributor: noonov <noonov@gmail.com>
+
+pkgname=ttf-umeplus
+pkgver=20150115
+pkgrel=1
+pkgdesc="Modified Ume and M+ fonts for Japanese"
+url="http://www.geocities.jp/ep3797/modified_fonts_01.html"
+license=('custom')
+arch=('any')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://downloads.sourceforge.net/mdk-ut/umeplus-fonts-${pkgver}.tar.lzma)
+md5sums=('bac6afe82549015be4b8c91d8401c9db')
+sha256sums=('032952bfe8fe5dceea354005bcac0a8c27116d222a4878fe9701f67cf4571e54')
+
+package() {
+ cd ${srcdir}/umeplus-fonts-${pkgver}
+
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF
+
+ install -D -m644 docs-mplus/LICENSE_E \
+ ${pkgdir}/usr/share/licenses/${pkgname}/COPYING_MPLUS.txt
+ install -D -m644 docs-ume/license.html \
+ ${pkgdir}/usr/share/licenses/${pkgname}/COPYING_UME.html
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..fab2a4227d83
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache /usr/share/fonts/TTF
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*
+