summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrocket2015-07-05 08:57:02 +0900
committercrocket2016-03-11 14:51:04 +0900
commita9e4023a77a61e9855a7e3b33e7392779688eb8e (patch)
tree88d2520115622f11ea6d0118e0120f4f40be6def
downloadaur-a9e4023a77a61e9855a7e3b33e7392779688eb8e.tar.gz
The first commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
-rw-r--r--ttf-unfonts-core.install15
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e322a520b1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ttf-unfonts-core
+ pkgdesc = It is a set of Korean TrueType fonts derived and slightly modified from the HLaTeX's PostScript fonts.
+ pkgver = 1.0.2
+ pkgrel = 7
+ url = http://kldp.net/projects/unfonts/
+ install = ttf-unfonts-core.install
+ arch = any
+ license = GPL
+ source = http://kldp.net/frs/download.php/4695/un-fonts-core-1.0.2-080608.tar.gz
+ sha256sums = 3b0a7274f9aab7e8f0f1938c01a70e1581766d51b494ba145683f37ac557918e
+
+pkgname = ttf-unfonts-core
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fd99acfbf38a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.xz
+*.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51d8f75ebf86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: crocket <crockabiscuit at gmail dot com>
+# Contributor: Wolfwood <wolfwood.thg at gmail dot com>
+
+pkgname=ttf-unfonts-core
+pkgver=1.0.2
+pkgrel=7
+pkgdesc="It is a set of Korean TrueType fonts derived and slightly modified from the HLaTeX's PostScript fonts."
+arch=('any')
+url="http://kldp.net/projects/unfonts/"
+license=('GPL')
+install=ttf-unfonts-core.install
+source=("http://kldp.net/frs/download.php/4695/un-fonts-core-1.0.2-080608.tar.gz")
+sha256sums=('3b0a7274f9aab7e8f0f1938c01a70e1581766d51b494ba145683f37ac557918e')
+
+package() {
+ fontdir=${pkgdir}/usr/share/fonts/TTF/
+ docdir=${pkgdir}/usr/share/doc/ttf-unfonts-core/
+ install -d $fontdir $docdir
+ install -D -m644 ${srcdir}/un-fonts/Un*.ttf $fontdir
+ install -D -m644 ${srcdir}/un-fonts/{COPYING,README} $docdir
+}
diff --git a/ttf-unfonts-core.install b/ttf-unfonts-core.install
new file mode 100644
index 000000000000..07bf317d8b2b
--- /dev/null
+++ b/ttf-unfonts-core.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}