summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkertase2015-08-11 10:35:34 +0200
committerkertase2015-08-11 10:35:34 +0200
commit8fd32cd41718382cb6496775903c72e125e9907a (patch)
tree008b87151eac53d56b750dc7600410609ad4f257
downloadaur-8fd32cd41718382cb6496775903c72e125e9907a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--ttf.install20
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40b626d02ff2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-unifont-csur
+ pkgdesc = TrueType version of the GNU Unifont with Michael Everson's ConScript Unicode Registry (CSUR) Private Use Area (PUA) glyphs
+ pkgver = 8.0.01
+ pkgrel = 1
+ url = http://unifoundry.com/unifont.html
+ install = ttf.install
+ arch = any
+ license = GPL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://unifoundry.com/pub/unifont-8.0.01/font-builds/unifont_csur-8.0.01.ttf
+ source = http://unifoundry.com/pub/unifont-8.0.01/font-builds/unifont_upper_csur-8.0.01.ttf
+ md5sums = c3a37a2a66f77f9c3c2c556056e123d2
+ md5sums = 8c9a0f32d4cfdb944a8bba6744e2648e
+
+pkgname = ttf-unifont-csur
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c789c45e7403
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: kertase <kertase at gmail dot com>
+
+pkgname=ttf-unifont-csur
+pkgver=8.0.01
+pkgrel=1
+pkgdesc="TrueType version of the GNU Unifont with Michael Everson's ConScript Unicode Registry (CSUR) Private Use Area (PUA) glyphs"
+url="http://unifoundry.com/unifont.html"
+arch=('any')
+license=('GPL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=ttf.install
+source=( http://unifoundry.com/pub/unifont-$pkgver/font-builds/unifont_csur-$pkgver.ttf
+http://unifoundry.com/pub/unifont-$pkgver/font-builds/unifont_upper_csur-$pkgver.ttf )
+md5sums=('c3a37a2a66f77f9c3c2c556056e123d2'
+'8c9a0f32d4cfdb944a8bba6744e2648e')
+
+package() {
+ cd $srcdir
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 unifont_csur-$pkgver.ttf $pkgdir/usr/share/fonts/TTF/Unifont_CSUR.ttf
+ install -m644 unifont_upper_csur-$pkgver.ttf $pkgdir/usr/share/fonts/TTF/Unifont_upper_CSUR.ttf
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..4f5212ef22ba
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*