summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregory Danielson2023-11-24 11:40:12 -0600
committerGregory Danielson2023-11-24 11:41:00 -0600
commitdd54fce84fe9dcf2d107e52240a48152b554a698 (patch)
treefadc76a77ea12770d85926e94085bd4a22aaa668
parent00b079f4399eb1633409e3e4af64838214b76a38 (diff)
downloadaur-dd54fce84fe9dcf2d107e52240a48152b554a698.tar.gz
Version 15.1.04-2 (Build from source)
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
3 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f881e55c27a9..82509187c6c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ttf-unifont-csur
pkgdesc = TrueType part of the GNU Unifont containing Michael Everson's ConScript Unicode Registry (CSUR) Private Use Area (PUA) glyphs
pkgver = 15.1.04
- pkgrel = 1
+ pkgrel = 2
url = https://unifoundry.com/unifont/index.html
arch = any
license = GPL
depends = ttf-unifont
- source = http://unifoundry.com/pub/unifont/unifont-15.1.04/font-builds/unifont_csur-15.1.04.ttf
- source = http://unifoundry.com/pub/unifont/unifont-15.1.04/font-builds/unifont_csur-15.1.04.ttf.sig
+ source = http://unifoundry.com/pub/unifont/unifont-15.1.04/unifont-15.1.04.tar.gz
+ source = http://unifoundry.com/pub/unifont/unifont-15.1.04/unifont-15.1.04.tar.gz.sig
validpgpkeys = 95D2E9AB8740D8046387FD151A09227B1F435A33
- sha512sums = 985e32f804e1101e1ca735460a8187646566e70f5691f59f8ede0a2744c9e81e90cbe67ebe2646be6cc00f71d94ff6d9ab8bd8358476b2b4dc8f51b39e3ed967
+ sha512sums = 0f3727708ecd75304b2e5d069c5c26e8673a624bf33c4d723e082faf3b2d3b33c73bb9b621ba8e90ddb8e1085dc1527e26a4754dd81f4e5445d53d4dacfef0e4
sha512sums = SKIP
pkgname = ttf-unifont-csur
diff --git a/.gitignore b/.gitignore
index 0a7b4dc2fcd6..d725ba4cf0d2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,3 @@
-*.ttf*
+*.tar.*
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 3144d1ef4560..92a1641a6788 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ttf-unifont-csur
pkgver=15.1.04
-pkgrel=1
+pkgrel=2
pkgdesc="TrueType part of the GNU Unifont containing Michael Everson's ConScript Unicode Registry (CSUR) Private Use Area (PUA) glyphs"
url="http://unifoundry.com/unifont.html"
arch=('any')
@@ -10,14 +10,19 @@ license=('GPL')
depends=('ttf-unifont')
url=https://unifoundry.com/unifont/index.html
source=(
- "http://unifoundry.com/pub/unifont/unifont-$pkgver/font-builds/unifont_csur-$pkgver.ttf"{,.sig}
+ "http://unifoundry.com/pub/unifont/unifont-${pkgver}/unifont-${pkgver}.tar.gz"{,.sig}
)
-sha512sums=('985e32f804e1101e1ca735460a8187646566e70f5691f59f8ede0a2744c9e81e90cbe67ebe2646be6cc00f71d94ff6d9ab8bd8358476b2b4dc8f51b39e3ed967'
+sha512sums=('0f3727708ecd75304b2e5d069c5c26e8673a624bf33c4d723e082faf3b2d3b33c73bb9b621ba8e90ddb8e1085dc1527e26a4754dd81f4e5445d53d4dacfef0e4'
'SKIP')
validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <com dot unifoundry at unifoundry>
+build() {
+ cd "${srcdir}/unifont-${pkgver}/font"
+ make hex
+ make csurttf
+}
+
package() {
cd "$srcdir"
- install -Dm644 "unifont_csur-$pkgver.ttf" \
- "$pkgdir/usr/share/fonts/TTF/Unifont_CSUR.ttf"
+ install -Dm644 "unifont-${pkgver}/font/compiled/unifont_csur-${pkgver}.ttf" "${pkgdir}/usr/share/fonts/TTF/Unifont_CSUR.ttf"
}