summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-05-11 07:14:57 -0400
committerErik Dubois2017-05-11 07:14:57 -0400
commitb205df9c1747da70d12ab601d694754dc4f2717f (patch)
treea7b21813ec20e9f9c5b7c66706a7e43c06c38cf2
downloadaur-b205df9c1747da70d12ab601d694754dc4f2717f.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--45-vollkorn.conf12
-rw-r--r--90-tt-vollkorn.conf26
-rw-r--r--PKGBUILD41
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc224ceaf7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu May 11 11:14:37 UTC 2017
+pkgbase = ttf-vollkorn-ibx
+ pkgdesc = Vollkorn typeface by Friedrich Althausen. TrueType version.
+ pkgver = 3.005
+ pkgrel = 5
+ url = http://vollkorn-typeface.com/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = custom:OFL
+ depends = fontconfig
+ conflicts = ttf-vollkorn
+ conflicts = otf-vollkorn
+ conflicts = otf-vollkorn-ibx
+ source = http://vollkorn-typeface.com/download/vollkorn-3-005.zip
+ source = 45-vollkorn.conf
+ source = 90-tt-vollkorn.conf
+ sha1sums = d65b1a5f61c9d84ef52e68ff699304351444e794
+ sha1sums = df82e0351eeae835feed489dc3394d0250d7b338
+ sha1sums = d6ac389486b0ed4439cde58fdd46df85a6c1a007
+
+pkgname = ttf-vollkorn-ibx
+
diff --git a/45-vollkorn.conf b/45-vollkorn.conf
new file mode 100644
index 000000000000..2ac103cebb8b
--- /dev/null
+++ b/45-vollkorn.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Vollkorn</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-vollkorn.conf b/90-tt-vollkorn.conf
new file mode 100644
index 000000000000..003b17c41ec2
--- /dev/null
+++ b/90-tt-vollkorn.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Vollkorn</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df481d2d01c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
+# Contributor: bohoomil <@zoho.com>
+
+pkgname=ttf-vollkorn-ibx
+pkgdesc="Vollkorn typeface by Friedrich Althausen. TrueType version."
+url=http://vollkorn-typeface.com/
+license=('custom:OFL')
+pkgver=3.005
+pkgrel=5
+depends=('fontconfig')
+conflicts=('ttf-vollkorn' 'otf-vollkorn' 'otf-vollkorn-ibx')
+groups=('infinality-bundle-fonts-extra')
+arch=('any')
+source=(http://vollkorn-typeface.com/download/vollkorn-${pkgver//./-}.zip
+ 45-vollkorn.conf
+ 90-tt-vollkorn.conf)
+sha1sums=('d65b1a5f61c9d84ef52e68ff699304351444e794'
+ 'df82e0351eeae835feed489dc3394d0250d7b338'
+ 'd6ac389486b0ed4439cde58fdd46df85a6c1a007')
+
+package() {
+ cd "${srcdir}"
+
+ install -D -m644 "OpenFontLicense.txt" \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+ install -D -m644 Fontlog.txt \
+ "${pkgdir}"/usr/share/doc/"${pkgname}"/Fontlog.txt
+ install -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 TTF/*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ install -m644 45-vollkorn.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-vollkorn.conf
+ install -m644 90-tt-vollkorn.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-vollkorn.conf
+
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-vollkorn.conf .
+ ln -s ../conf.avail/90-tt-vollkorn.conf .
+}