summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiloš2016-03-26 15:17:05 +0100
committerMiloš2016-03-26 15:17:05 +0100
commit6de4571b5d1929edd5f97eee324e78e58ea8b8bc (patch)
tree5ea04c2aca33226a979fd51ac19dfd160e0ae345
parent164cbd7a7631c72206e703a4563d5b9ed519399e (diff)
downloadaur-6de4571b5d1929edd5f97eee324e78e58ea8b8bc.tar.gz
remove the hyphen from font's name during install
Several applications had problems loading the glyphs because of the '-'. I already reported these bugs, so this _might_ be just a temporary fix.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rwxr-xr-xrename.pe4
3 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0c665ef8669..7fd4d898040c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = ttf-webhostinghub-glyphs
- pkgdesc = WebHostingHub-Glyphs icon font by webhostinghub.com
+ pkgdesc = WebHostingHub Glyphs icon font by webhostinghub.com
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.webhostinghub.com/glyphs/
install = ttf-webhostinghub-glyphs.install
arch = any
license = OFL
depends = fontconfig
depends = xorg-font-utils
+ depends = fontforge
source = http://www.webhostinghub.com/glyphs/resources/whhg-font.zip
md5sums = 09993f3df25fa9edfca8b856b23c1425
diff --git a/PKGBUILD b/PKGBUILD
index faf3a92eb051..a86d0ffe8473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=ttf-webhostinghub-glyphs
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='WebHostingHub Glyphs icon font by webhostinghub.com'
arch=('any')
url='http://www.webhostinghub.com/glyphs/'
license=('OFL')
-depends=('fontconfig' 'xorg-font-utils')
+depends=('fontconfig' 'xorg-font-utils' 'fontforge')
install=ttf-webhostinghub-glyphs.install
source=('http://www.webhostinghub.com/glyphs/resources/whhg-font.zip')
md5sums=('09993f3df25fa9edfca8b856b23c1425')
@@ -15,4 +15,5 @@ md5sums=('09993f3df25fa9edfca8b856b23c1425')
package() {
install -d $pkgdir/usr/share/fonts/TTF/
install -m644 $srcdir/whhg-font/font/*.ttf $pkgdir/usr/share/fonts/TTF/
+ ../rename.pe $pkgdir/usr/share/fonts/TTF/webhostinghub-glyphs.ttf
}
diff --git a/rename.pe b/rename.pe
new file mode 100755
index 000000000000..f9d68ec7d6a9
--- /dev/null
+++ b/rename.pe
@@ -0,0 +1,4 @@
+#!/usr/bin/env fontforge
+Open($1)
+SetFontNames('WebHostingHubGlyphs', 'WebHostingHubGlyphs', 'WebHostingHubGlyphs')
+Generate($1:r + ".ttf")