summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Mikhayloff2016-12-21 18:54:15 +0300
committerRoman Mikhayloff2016-12-21 18:54:15 +0300
commit2b44b80dd8aa8951672457b9ba3026da27733297 (patch)
tree27b11a2746d73eb49ba378369a310931df6a1376
downloadaur-2b44b80dd8aa8951672457b9ba3026da27733297.tar.gz
add ttf-xo-symbol package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--ttf-xo-symbol.install15
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15596646a0f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-xo-symbol
+ pkgdesc = XO Symbol font created considering trends of modern typography from «Новые облачные технологии»
+ pkgver = 1.00
+ pkgrel = 1
+ url = https://fonts.myoffice.ru
+ install = ttf-xo-symbol.install
+ arch = any
+ license = custom: XO FONTS Open License
+ makedepends = dos2unix
+ makedepends = glibc
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = XO_Symbol-1.00.zip::http://fonts.myoffice.ru/wp-content/themes/template/fonts_page/files/XO_Symbol.zip
+ sha256sums = 5e8d33954c142b76dd94f541cd43d8f320514b5eef2ce70efb8abf7536e80fde
+
+pkgname = ttf-xo-symbol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfaef47f7585
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Roman Mikhayloff <rimf@inbox.ru>
+
+pkgname=ttf-xo-symbol
+pkgver=1.00 # The fake version, the original is unversioned.
+pkgrel=1
+pkgdesc="XO Symbol font created considering trends of modern typography from «Новые облачные технологии»"
+arch=('any')
+url="https://fonts.myoffice.ru"
+license=('custom: XO FONTS Open License')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('dos2unix' 'glibc')
+source=("XO_Symbol-${pkgver}.zip::http://fonts.myoffice.ru/wp-content/themes/template/fonts_page/files/XO_Symbol.zip")
+sha256sums=('5e8d33954c142b76dd94f541cd43d8f320514b5eef2ce70efb8abf7536e80fde')
+install=${pkgname}.install
+
+prepare() {
+ iconv -f cp1251 -t utf8 -o LICENSE XO_Fonts_License.txt
+ dos2unix LICENSE
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+
+ cd "${srcdir}"
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/ttf-xo-symbol.install b/ttf-xo-symbol.install
new file mode 100644
index 000000000000..724145fffa8a
--- /dev/null
+++ b/ttf-xo-symbol.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}