summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Mikhayloff2016-12-21 18:21:37 +0300
committerRoman Mikhayloff2016-12-21 18:21:37 +0300
commit1ff9658ba4cb1bb5a547890d22ab84d344600896 (patch)
tree04958986a025e486c468e34fa599e699bea5c61c
downloadaur-1ff9658ba4cb1bb5a547890d22ab84d344600896.tar.gz
add ttf-xo-tahion package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--ttf-xo-tahion.install15
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5b04da987f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-xo-tahion
+ pkgdesc = XO Tahion font created considering trends of modern typography from «Новые облачные технологии»
+ pkgver = 1.00
+ pkgrel = 1
+ url = https://fonts.myoffice.ru
+ install = ttf-xo-tahion.install
+ arch = any
+ license = custom: XO FONTS Open License
+ makedepends = dos2unix
+ makedepends = glibc
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = XO_Tahion-1.00.zip::http://fonts.myoffice.ru/wp-content/themes/template/fonts_page/files/XO_Tahion.zip
+ sha256sums = 70c10e31caeb5a2006527d8005f96ca38dd3ddabe30b7829dfed5a02c290b1c1
+
+pkgname = ttf-xo-tahion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91e4a0580d16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Roman Mikhayloff <rimf@inbox.ru>
+
+pkgname=ttf-xo-tahion
+pkgver=1.00 # The fake version, the original is unversioned.
+pkgrel=1
+pkgdesc="XO Tahion font created considering trends of modern typography from «Новые облачные технологии»"
+arch=('any')
+url="https://fonts.myoffice.ru"
+license=('custom: XO FONTS Open License')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('dos2unix' 'glibc')
+source=("XO_Tahion-${pkgver}.zip::http://fonts.myoffice.ru/wp-content/themes/template/fonts_page/files/XO_Tahion.zip")
+sha256sums=('70c10e31caeb5a2006527d8005f96ca38dd3ddabe30b7829dfed5a02c290b1c1')
+install=${pkgname}.install
+
+prepare() {
+ iconv -f cp1251 -t utf8 -o LICENSE XO_Fonts_License.txt
+ dos2unix LICENSE
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+
+ cd "${srcdir}"
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/ttf-xo-tahion.install b/ttf-xo-tahion.install
new file mode 100644
index 000000000000..724145fffa8a
--- /dev/null
+++ b/ttf-xo-tahion.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}