summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McCurry2017-02-22 11:44:29 -0500
committerDan McCurry2017-02-22 11:44:29 -0500
commit8720dc78979dbeffeea0a2927640d3ff32365cb3 (patch)
tree9abbff536c5d491bb4dee5977bb593ff93853aec
downloadaur-8720dc78979dbeffeea0a2927640d3ff32365cb3.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--COPYRIGHT8
-rw-r--r--PKGBUILD42
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d5f05ca068c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ttf-y14.5m
+ pkgdesc = Mechanical engineering fonts with regards to the ASME Y14.5 standard.
+ pkgver = 1
+ pkgrel = 1
+ url = https://cstools.asme.org/csconnect/CommitteePages.cfm?Committee=C64000000&Action=40068
+ arch = any
+ license = custom:copyright
+ source = http://www.fontspace.com/download/9006/862de5cd3f6f417f9e56e9d12fa58f5d/micronus_y145m-2009.zip
+ source = http://www.fontspace.com/download/6341/b1f81ad37c364d9e8122079657d70035/micronus_y145m.zip
+ source = http://www.fontspace.com/download/9007/dc81ff928cab49bfaedfef825b5c8762/micronus_weldsymbols.zip
+ source = local://COPYRIGHT
+ md5sums = 81178ab98fe87ccdc9a0926521f9bde1
+ md5sums = 9974425c007a3b8cc83c5f4a38143cac
+ md5sums = 1d765e5f492606fd729e0d307ccec636
+ md5sums = bdfa36bc4ecf87278f63e64dfee002c6
+
+pkgname = ttf-y14.5m
+ provides = ttf-y14.5m
+
+pkgname = ttf-y14.5m-docs
+ pkgdesc = Mechanical engineering fonts with regards to the ASME Y14.5 standard. (docs)
+ depends = ttf-y14.5m
+
diff --git a/COPYRIGHT b/COPYRIGHT
new file mode 100644
index 000000000000..9df3b4a12833
--- /dev/null
+++ b/COPYRIGHT
@@ -0,0 +1,8 @@
+Y14.5M-2009.ttf & WeldSymbols.ttf
+© Peter Kanold 2010
+
+These fonts are public domain freeware - copying & redistributing it is
+encouraged.
+
+You may use them in what ever personal or commercial way you would like. Credit
+to me if it is used in a commercial package would be nice but is not mandatory.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a04eeeee5c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+
+pkgname=('ttf-y14.5m' 'ttf-y14.5m-docs')
+pkgver=1
+pkgrel=1
+pkgdesc="Mechanical engineering fonts with regards to the ASME Y14.5 standard."
+arch=('any')
+url="https://cstools.asme.org/csconnect/CommitteePages.cfm?Committee=C64000000&Action=40068"
+license=('custom:copyright')
+source=('http://www.fontspace.com/download/9006/862de5cd3f6f417f9e56e9d12fa58f5d/micronus_y145m-2009.zip'
+ 'http://www.fontspace.com/download/6341/b1f81ad37c364d9e8122079657d70035/micronus_y145m.zip'
+ 'http://www.fontspace.com/download/9007/dc81ff928cab49bfaedfef825b5c8762/micronus_weldsymbols.zip'
+ 'local://COPYRIGHT')
+md5sums=('81178ab98fe87ccdc9a0926521f9bde1'
+ '9974425c007a3b8cc83c5f4a38143cac'
+ '1d765e5f492606fd729e0d307ccec636'
+ 'bdfa36bc4ecf87278f63e64dfee002c6')
+
+package_ttf-y14.5m() {
+ provides=('ttf-y14.5m')
+
+ cd ${srcdir}
+ for font in *.ttf; do
+ install -Dm644 $font "${pkgdir}/usr/share/fonts/TTF/$font"
+ done
+ install -Dm644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+}
+
+package_ttf-y14.5m-docs() {
+ pkgdesc="$pkgdesc (docs)"
+ depends=("$pkgbase")
+
+ cd ${srcdir}
+ install -Dm644 FontTable.pdf \
+ "${pkgdir}/usr/share/doc/${pkgname}/fonttable.pdf"
+ install -Dm644 "Y15 5M-2009FontInfo.pdf" \
+ "${pkgdir}/usr/share/doc/${pkgname}/fontinfo.pdf"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/share/licenses/${pkgbase}/COPYRIGHT" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+}