summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-09-15 13:52:16 +0100
committerGrey Christoforo2015-09-15 13:52:16 +0100
commit8f189828d8174c4b6e66235da1371bfba9fb4b15 (patch)
tree91d5539d14735a0322106e01a3fbc881e53e28d7
downloadaur-8f189828d8174c4b6e66235da1371bfba9fb4b15.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
-rw-r--r--need_math.patch10
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9866d1695d1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf2cxf
+ pkgdesc = Converts ttf fonts to xcf
+ pkgver = 0.0.0.1
+ pkgrel = 1
+ url = https://github.com/Ultimaker/libArcus
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = freetype2
+ depends = python-protobuf3
+ source = ftp://ribbonsoft.com/archives/ttf2cxf/ttf2cxf-0.0.0.1-src.tar.gz
+ source = need_math.patch
+ md5sums = 3388e3a52b7a8f692c9af1510dda6031
+ md5sums = 66aa899fccdabc54363b13a7eb23edd9
+
+pkgname = ttf2cxf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d070288e95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=ttf2cxf
+pkgver=0.0.0.1
+pkgrel=1
+pkgdesc="Converts ttf fonts to xcf"
+url="https://github.com/Ultimaker/libArcus"
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=('freetype2' 'python-protobuf3')
+source=(ftp://ribbonsoft.com/archives/ttf2cxf/ttf2cxf-0.0.0.1-src.tar.gz need_math.patch)
+md5sums=('3388e3a52b7a8f692c9af1510dda6031'
+ '66aa899fccdabc54363b13a7eb23edd9')
+
+prepare() {
+ cd ${pkgname}-${pkgver}-src
+ patch < ../need_math.patch
+}
+
+build() {
+ cd ${pkgname}-${pkgver}-src
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}-src
+ install -Dm755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
+ cd "$pkgdir/usr/bin/"
+ ln -s ${pkgname} ${pkgname}_stream
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/need_math.patch b/need_math.patch
new file mode 100644
index 000000000000..bba171559fd3
--- /dev/null
+++ b/need_math.patch
@@ -0,0 +1,10 @@
+--- main.cpp 2015-09-15 13:40:17.186083360 +0100
++++ main.cpp.new 2015-09-15 13:38:40.294697474 +0100
+@@ -23,6 +23,7 @@
+ #include <iostream>
+
+ #include <ft2build.h>
++#include <math.h>
+ #include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+ #include FT_GLYPH_H