summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-04-14 16:31:14 +0300
committerCaleb Maclennan2020-04-30 17:09:35 +0300
commit54ece8eadf385be94dc54db960968d38fe1d09bf (patch)
treee6ef8d4ee577434bb314e734d4216875e9c955b7
parent33b09e8ffe18e2eb4231f743be26a5818c40b83d (diff)
downloadaur-54ece8eadf385be94dc54db960968d38fe1d09bf.tar.gz
upgpkg: ttfautohint 1.8.3-2
Adopt and overhaul packaging to use prebuilt docs and fix dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD42
2 files changed, 23 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9db14210dc1..835d5a63a76e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = ttfautohint
- pkgdesc = Provides automated hinting process for web fonts.
+ pkgdesc = Provides automated hinting process for web fonts
pkgver = 1.8.3
- pkgrel = 1
- url = http://www.freetype.org/ttfautohint/
+ pkgrel = 2
+ url = http://www.freetype.org/ttfautohint
arch = i686
arch = x86_64
license = GPL
license = custom
depends = freetype2
+ depends = harfbuzz
depends = qt5-base
- depends = noto-fonts
- depends = noto-fonts-alpha
- optdepends = texlive-bin: generate docs
- optdepends = pandoc: generate docs
- optdepends = ghc: pandoc filter
source = https://download.savannah.gnu.org/releases/freetype/ttfautohint-1.8.3.tar.gz
source = https://download.savannah.gnu.org/releases/freetype/ttfautohint-1.8.3.tar.gz.sig
validpgpkeys = 58E0C111E39F5408C5D3EC76C1A60EACE707FDA5
diff --git a/PKGBUILD b/PKGBUILD
index f07d03ba36f2..5abee7649607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,39 @@
# Maintainer: Mario Finelli <mario at finel dot li>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: Arthur Titeica <arthur dot titeica at gmail dot com>
pkgname=ttfautohint
pkgver=1.8.3
-pkgrel=1
-pkgdesc="Provides automated hinting process for web fonts."
+pkgrel=2
+pkgdesc='Provides automated hinting process for web fonts'
arch=('i686' 'x86_64')
-url="http://www.freetype.org/ttfautohint/"
+url="http://www.freetype.org/$pkgname"
license=('GPL' 'custom')
-depends=('freetype2' 'qt5-base' 'noto-fonts' 'noto-fonts-alpha')
-optdepends=('texlive-bin: generate docs'
- 'pandoc: generate docs'
- 'ghc: pandoc filter')
+depends=('freetype2' 'harfbuzz' 'qt5-base')
source=(https://download.savannah.gnu.org/releases/freetype/$pkgname-$pkgver.tar.gz{,.sig})
sha256sums=('87bb4932571ad57536a7cc20b31fd15bc68cb5429977eb43d903fa61617cf87e'
'SKIP')
validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- export QMAKE='/usr/bin/qmake'
- export MOC='/usr/bin/moc'
- export UIC='/usr/bin/uic'
- export RCC='/usr/bin/rcc'
- export TTFONTS='/usr/share/fonts/noto'
- ./configure --prefix=/usr --with-qt=/usr/lib/qt \
- --with-freetype-config="pkg-config freetype2"
- make
+ cd "$pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --without-doc \
+ --with-qt=/usr/lib/qt \
+ --with-freetype-config="pkg-config freetype2"
+ make
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
- make -k check
+ cd "$pkgname-$pkgver"
+ make -k check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
-
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- install -Dm644 FTL.TXT "${pkgdir}/usr/share/licenses/${pkgname}/FTL.TXT"
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING FTL.TXT
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" "doc/$pkgname.pdf"
+ install -Dm644 -t "$pkgdir/usr/share/man/man1/" "frontend/$pkgname"{,GUI}.1
}