summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2017-04-18 19:30:59 -0400
committerMario Finelli2017-04-18 19:30:59 -0400
commit083dfc8f07a3b16f36f579806bdd5efbe80ddf67 (patch)
treefc520ffb54e6be56c4b8141c5e19c1b2f4174334
parent84411da428d6f6be7aa1e52c22973646a215a03d (diff)
downloadaur-083dfc8f07a3b16f36f579806bdd5efbe80ddf67.tar.gz
Use qt5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d3cdd26b3cb..0c11d916f166 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Dec 15 23:43:06 UTC 2016
+# Tue Apr 18 23:30:35 UTC 2017
pkgbase = ttfautohint
pkgdesc = Provides automated hinting process for web fonts.
pkgver = 1.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.freetype.org/ttfautohint/
arch = i686
arch = x86_64
license = GPL
license = custom
depends = freetype2
- depends = qt4
+ depends = qt5-base
optdepends = texlive-bin: generate docs
optdepends = pandoc: generate docs
optdepends = ghc: pandoc filter
diff --git a/PKGBUILD b/PKGBUILD
index 5b8053ef5488..5abb3e76e045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=ttfautohint
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc="Provides automated hinting process for web fonts."
arch=('i686' 'x86_64')
url="http://www.freetype.org/ttfautohint/"
license=('GPL' 'custom')
-depends=('freetype2' 'qt4')
+depends=('freetype2' 'qt5-base')
optdepends=('texlive-bin: generate docs'
'pandoc: generate docs'
'ghc: pandoc filter')
@@ -19,13 +19,11 @@ validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
build() {
cd "$srcdir/$pkgname-$pkgver"
- export QMAKE='/usr/bin/qmake-qt4'
- export MOC='/usr/bin/moc-qt4'
- export UIC='/usr/bin/uic-qt4'
- export RCC='/usr/bin/rcc-qt4'
- # export QTDIR='/usr/lib/qt4'
- # CFLAGS="-I/usr/include/qt4"
- ./configure --prefix=/usr --with-qt=/usr/lib/qt4
+ export QMAKE='/usr/bin/qmake'
+ export MOC='/usr/bin/moc'
+ export UIC='/usr/bin/uic'
+ export RCC='/usr/bin/rcc'
+ ./configure --prefix=/usr --with-qt=/usr/lib/qt
make
}