summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-04-14 16:57:43 +0300
committerCaleb Maclennan2020-04-14 16:57:43 +0300
commitba43288efe578212999d28836bd6296af19e1424 (patch)
treed03bf5140da517f8921e4385d759e0ca0245cc1c
parent33b09e8ffe18e2eb4231f743be26a5818c40b83d (diff)
downloadaur-ba43288efe578212999d28836bd6296af19e1424.tar.gz
Adapt stable package as VCS
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD75
2 files changed, 63 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9db14210dc1..5a25e3609ba3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
-pkgbase = ttfautohint
- pkgdesc = Provides automated hinting process for web fonts.
- pkgver = 1.8.3
+pkgbase = ttfautohint-git
+ pkgdesc = Provides automated hinting process for web fonts
+ pkgver = 1.8.3.r16.g701aa67
pkgrel = 1
- url = http://www.freetype.org/ttfautohint/
+ url = http://www.freetype.org/ttfautohint
arch = i686
arch = x86_64
license = GPL
license = custom
+ makedepends = pandoc
+ makedepends = inkscape
+ makedepends = imagemagick
+ makedepends = noto-fonts
+ makedepends = texlive-core
+ makedepends = xorg-xwininfo
depends = freetype2
+ depends = harfbuzz
depends = qt5-base
- depends = noto-fonts
- depends = noto-fonts-alpha
- optdepends = texlive-bin: generate docs
- optdepends = pandoc: generate docs
- optdepends = ghc: pandoc filter
- source = https://download.savannah.gnu.org/releases/freetype/ttfautohint-1.8.3.tar.gz
- source = https://download.savannah.gnu.org/releases/freetype/ttfautohint-1.8.3.tar.gz.sig
- validpgpkeys = 58E0C111E39F5408C5D3EC76C1A60EACE707FDA5
- sha256sums = 87bb4932571ad57536a7cc20b31fd15bc68cb5429977eb43d903fa61617cf87e
+ source = git://repo.or.cz/ttfautohint.git
+ source = git://git.sv.gnu.org/gnulib.git
+ sha256sums = SKIP
sha256sums = SKIP
-pkgname = ttfautohint
+pkgname = ttfautohint-git
diff --git a/PKGBUILD b/PKGBUILD
index f07d03ba36f2..addb432b8b51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,64 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Maintainer: Mario Finelli <mario at finel dot li>
# Contributor: Arthur Titeica <arthur dot titeica at gmail dot com>
-pkgname=ttfautohint
-pkgver=1.8.3
+pkgname=ttfautohint-git
+pkgver=1.8.3.r16.g701aa67
pkgrel=1
-pkgdesc="Provides automated hinting process for web fonts."
+pkgdesc='Provides automated hinting process for web fonts'
arch=('i686' 'x86_64')
-url="http://www.freetype.org/ttfautohint/"
+url="http://www.freetype.org/${pkgname%-git}"
license=('GPL' 'custom')
-depends=('freetype2' 'qt5-base' 'noto-fonts' 'noto-fonts-alpha')
-optdepends=('texlive-bin: generate docs'
- 'pandoc: generate docs'
- 'ghc: pandoc filter')
-source=(https://download.savannah.gnu.org/releases/freetype/$pkgname-$pkgver.tar.gz{,.sig})
-sha256sums=('87bb4932571ad57536a7cc20b31fd15bc68cb5429977eb43d903fa61617cf87e'
+depends=('freetype2' 'harfbuzz' 'qt5-base')
+makedepends=('pandoc'
+ 'inkscape'
+ 'imagemagick'
+ 'noto-fonts'
+ # 'noto-fonts-alpha'
+ 'texlive-core'
+ 'xorg-xwininfo')
+source=("git://repo.or.cz/${pkgname/-/.}"
+ "git://git.sv.gnu.org/gnulib.git")
+sha256sums=('SKIP'
'SKIP')
-validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --tags --abbrev=7 --match="v*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd "${pkgname%-git}"
+ git submodule init
+ git config submodule.gnulib.url "$srcdir/gnulib"
+ git submodule update
+ echo "GNULIB_URL='$srcdir/gnulib'" > bootstrap.conf
+ sed -i -e '400s/yes/no/' bootstrap
+ ./bootstrap --force
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- export QMAKE='/usr/bin/qmake'
- export MOC='/usr/bin/moc'
- export UIC='/usr/bin/uic'
- export RCC='/usr/bin/rcc'
- export TTFONTS='/usr/share/fonts/noto'
- ./configure --prefix=/usr --with-qt=/usr/lib/qt \
- --with-freetype-config="pkg-config freetype2"
- make
+ cd "${pkgname%-git}"
+ export QMAKE='/usr/bin/qmake'
+ export MOC='/usr/bin/moc'
+ export UIC='/usr/bin/uic'
+ export RCC='/usr/bin/rcc'
+ export TTFONTS='/usr/share/fonts/noto'
+ ./configure \
+ --prefix=/usr \
+ --with-qt=/usr/lib/qt \
+ --with-freetype-config="pkg-config freetype2"
+ make
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
- make -k check
+ cd "${pkgname%-git}"
+ make -k check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
-
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- install -Dm644 FTL.TXT "${pkgdir}/usr/share/licenses/${pkgname}/FTL.TXT"
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING FTL.TXT
}