summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-01-18 14:40:09 +0100
committerChristopher Arndt2016-01-18 14:40:09 +0100
commitc33ae2af1d962a70f81d1f99f8313af9a4e5bce7 (patch)
treed3cd96bbb4cdb680beef42af6638f73242fcb3d5
downloadaur-c33ae2af1d962a70f81d1f99f8313af9a4e5bce7.tar.gz
Initial commit of new package 'ttl2c-git'
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD38
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92f8b15df827
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 13:39:13 UTC 2016
+pkgbase = ttl2c-git
+ pkgdesc = Turtle to header conversion utility for LV2 Plugin developers
+ pkgver = r1.b09ea6d
+ pkgrel = 1
+ url = https://github.com/lvtk/ttl2c
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = boost-libs
+ provides = ttl2c
+ conflicts = ttl2c
+ source = ttl2c::git+https://github.com/lvtk/ttl2c.git
+ md5sums = SKIP
+
+pkgname = ttl2c-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2c634f107eb5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+ttl2c
+src
+pkg
+ttl2c-git-*.tar.xz
+ttl2c-git-*.src.tar.gz
+.AURINFO
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1784b08d2f8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=ttl2c
+pkgname="${_pkgname}-git"
+pkgver=r1.b09ea6d
+pkgrel=1
+pkgdesc="Turtle to header conversion utility for LV2 Plugin developers "
+arch=('i686' 'x86_64')
+url="https://github.com/lvtk/ttl2c"
+license=('GPL3')
+depends=('boost-libs')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/lvtk/ttl2c.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ export LDFLAGS="-lboost_system"
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ python2 waf install --destdir="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: