summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-07-09 07:36:41 +0200
committerCarsten Teibes2014-07-09 07:36:41 +0200
commit771ebf4080bce89039ca9d072f0009b561c8a303 (patch)
treecc44ae2b1b7a54b21758db188b87d73e9ad82e61
downloadaur-771ebf4080bce89039ca9d072f0009b561c8a303.tar.gz
[add] ttm_unpack 20121203
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59d0286d994d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttm_unpack
+ pkgdesc = An extractor for datafiles of 'To the Moon' and other games based on the RPG Maker XP engine
+ pkgver = 20121203
+ pkgrel = 1
+ url = http://davidgow.net/hacks/ttm_unpack.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://davidgow.net/files/ttm_unpack.c
+ sha256sums = d894c724521e29b95dd22c378ef28e4e470769c75fb8c902ce6192f542bb7804
+
+pkgname = ttm_unpack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3edf3072431a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=ttm_unpack
+pkgver=20121203
+pkgrel=1
+pkgdesc="An extractor for datafiles of 'To the Moon' and other games based on the RPG Maker XP engine"
+arch=('i686' 'x86_64')
+url="http://davidgow.net/hacks/ttm_unpack.html"
+license=('custom')
+depends=('glibc')
+source=("http://davidgow.net/files/ttm_unpack.c")
+sha256sums=('d894c724521e29b95dd22c378ef28e4e470769c75fb8c902ce6192f542bb7804')
+
+build () {
+ # compile with our flags
+ gcc $CFLAGS ttm_unpack.c $LDFLAGS -o ttm_unpack
+}
+
+package () {
+ install -Dm755 ttm_unpack "$pkgdir"/usr/bin/ttm_unpack
+ # license
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ head -n 17 ttm_unpack.c > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}