summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo2020-05-03 13:40:48 +0200
committerDanilo2020-05-03 13:40:48 +0200
commit6a11b53e470e8fa63e5d9cd17adb99924e45a61c (patch)
tree353fb19d772431715e560370ed73bb45ff5145f5
parent8c38a55872b50c15c7c96800395ec7b319c57713 (diff)
downloadaur-6a11b53e470e8fa63e5d9cd17adb99924e45a61c.tar.gz
Version 2.10.4-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 869a28122539..25aecae4ff53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 10 08:39:20 UTC 2017
+# Sun May 3 11:40:35 UTC 2020
pkgbase = ttnctl-bin
pkgdesc = Command line tool for The Things Network (TTN)
- pkgver = 2.8.0
- pkgrel = 3
+ pkgver = 2.10.4
+ pkgrel = 1
url = https://www.thethingsnetwork.org/docs/network/cli/quick-start.html
arch = i686
arch = x86_64
@@ -11,17 +11,17 @@ pkgbase = ttnctl-bin
license = MIT
makedepends = gnupg
provides = ttnctl
- source = https://ttnreleases.blob.core.windows.net/release/v2.8.0/checksums
- source = https://ttnreleases.blob.core.windows.net/release/v2.8.0/checksums.sig
+ source = https://ttnreleases.blob.core.windows.net/release/v2.10.4/checksums
+ source = https://ttnreleases.blob.core.windows.net/release/v2.10.4/checksums.sig
source = https://raw.githubusercontent.com/TheThingsNetwork/ttn/develop/LICENSE
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- source_i686 = https://ttnreleases.blob.core.windows.net/release/v2.8.0/ttnctl-linux-386.tar.gz
+ source_i686 = https://ttnreleases.blob.core.windows.net/release/v2.10.4/ttnctl-linux-386.tar.gz
sha256sums_i686 = SKIP
- source_x86_64 = https://ttnreleases.blob.core.windows.net/release/v2.8.0/ttnctl-linux-amd64.tar.gz
+ source_x86_64 = https://ttnreleases.blob.core.windows.net/release/v2.10.4/ttnctl-linux-amd64.tar.gz
sha256sums_x86_64 = SKIP
- source_arm = https://ttnreleases.blob.core.windows.net/release/v2.8.0/ttnctl-linux-arm.tar.gz
+ source_arm = https://ttnreleases.blob.core.windows.net/release/v2.10.4/ttnctl-linux-arm.tar.gz
sha256sums_arm = SKIP
pkgname = ttnctl-bin
diff --git a/PKGBUILD b/PKGBUILD
index 720501135030..063bcd749174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+# Import the PGP key first: gpg --recv-key 2F062CD1542547AF71BD9B818FC5CD2B9DFB1B4B
+# You can also find that key referenced here: https://www.thethingsnetwork.org/docs/network/cli/quick-start.html
pkgname=ttnctl-bin
-pkgver=2.8.0
-pkgrel=3
+pkgver=2.10.4
+pkgrel=1
pkgdesc="Command line tool for The Things Network (TTN)"
arch=('i686' 'x86_64' 'arm')
url="https://www.thethingsnetwork.org/docs/network/cli/quick-start.html"
@@ -20,10 +22,13 @@ source=(
source_i686=("${_baseurl}/v${pkgver}/ttnctl-linux-386.tar.gz")
source_x86_64=("${_baseurl}/v${pkgver}/ttnctl-linux-amd64.tar.gz")
source_arm=("${_baseurl}/v${pkgver}/ttnctl-linux-arm.tar.gz")
+
+# Skipping checksums since we validate against the PGP signed checksum file instead
sha256sums=('SKIP' 'SKIP' 'SKIP')
sha256sums_i686=('SKIP')
sha256sums_x86_64=('SKIP')
sha256sums_arm=('SKIP')
+
validpgpkeys=('2F062CD1542547AF71BD9B818FC5CD2B9DFB1B4B')
if [ "$CARCH" == "i686" ]; then
@@ -35,7 +40,9 @@ elif [ "$CARCH" == "arm" ]; then
fi
prepare() {
+ echo "Validating checksums..."
cat checksums | grep $_binname | sha256sum -c --quiet
+ echo "Checksums valid!"
}
package() {