summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-18 21:55:23 +0800
committerzxp198210052023-07-18 21:55:23 +0800
commitc1a7d26adfb5f0e4570077f2e7cf3565f8d58ca5 (patch)
treed654ace58704e63bf31c5dfda92a2049ea403d92
downloadaur-c1a7d26adfb5f0e4570077f2e7cf3565f8d58ca5.tar.gz
first release
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD29
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98b7f0f6dca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = tts-vue
+ pkgdesc = Microsoft speech synthesis tool, built using Electron+Vue+ElementPlus+Vite.微软语音合成工具,使用Electron+Vue+ElementPlus+Vite构建。
+ pkgver = 1.9.12
+ pkgrel = 1
+ url = https://tts-doc.loker.vip/home.html
+ arch = x86_64
+ license = MIT
+ makedepends = yarn
+ makedepends = gendesk
+ depends = glibc
+ depends = libdrm
+ depends = mesa
+ depends = expat
+ depends = nss
+ depends = cairo
+ depends = gtk3
+ depends = dbus
+ depends = libxcb
+ depends = nspr
+ depends = pango
+ depends = libxkbcommon
+ depends = glib2
+ depends = at-spi2-core
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libx11
+ depends = gcc-libs
+ depends = libxrandr
+ depends = alsa-lib
+ depends = libcups
+ depends = libxext
+ depends = libxfixes
+ conflicts = tts-vue
+ source = tts-vue-1.9.12.tar.gz::https://github.com/LokerL/tts-vue/archive/refs/tags/1.9.12.tar.gz
+ sha256sums = 9f08ee3bf7beb95bef8842c4858681dcb93c2a507fcec3c8443d01bc54ec1617
+
+pkgname = tts-vue
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7898936a0f05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="tts-vue"
+pkgver=1.9.12
+pkgrel=1
+pkgdesc="Microsoft speech synthesis tool, built using Electron+Vue+ElementPlus+Vite.微软语音合成工具,使用Electron+Vue+ElementPlus+Vite构建。"
+arch=('x86_64')
+url="https://tts-doc.loker.vip/home.html"
+_githuburl="https://github.com/LokerL/tts-vue"
+license=('MIT')
+conflicts=("${pkgname}")
+depends=('glibc' 'libdrm' 'mesa' 'expat' 'nss' 'cairo' 'gtk3' 'dbus' 'libxcb' 'nspr' 'pango' 'libxkbcommon' 'glib2' 'at-spi2-core' \
+ 'libxcomposite' 'libxdamage' 'libx11' 'gcc-libs' 'libxrandr' 'alsa-lib' 'libcups' 'libxext' 'libxfixes')
+makedepends=('yarn' 'gendesk')
+_install_path="/opt/appimages"
+source=("${pkgname}-${pkgver}.tar.gz::${_githuburl}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('9f08ee3bf7beb95bef8842c4858681dcb93c2a507fcec3c8443d01bc54ec1617')
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ yarn install
+ yarn build
+}
+package() {
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 -d "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/release/${pkgver}/linux-unpacked/"* "${pkgdir}/opt/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/dist/node.png" -t "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ gendesk -f -n --icon "${pkgname}" --categories "Utility" --name "${pkgname}" --exec "/opt/${pkgname}/${pkgname} --no-sandbox %U"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file