summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2019-05-10 15:39:04 +1000
committerVictor Tran2019-05-10 15:39:04 +1000
commitac0f594fae032c36e8d837cba5d472c2f59ca456 (patch)
tree99bb655f0ff3d98c463f2a1c4212eb413437187d
parent7398c2693ffa19873c72f907d082706ee5ad18d3 (diff)
downloadaur-ac0f594fae032c36e8d837cba5d472c2f59ca456.tar.gz
Move to QMake
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5395c37b03f5..8327fa86e4d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = tttermwidget
- pkgdesc = A terminal widget for Qt
- pkgver = 0.6.0
- pkgrel = 2
+ pkgdesc = Terminal widget used by theTerminal
+ pkgver = 1.0
+ pkgrel = 1
url = https://github.com/vicr123/tttermwidget
arch = i686
arch = x86_64
license = GPL2
- makedepends = cmake
depends = qt5-base
depends = libsm
depends = libxkbcommon-x11
- source = tttermwidget-0.6.0::git+https://github.com/vicr123/tttermwidget
+ depends = libutf8proc
+ depends = the-libs
+ source = tttermwidget-1.0::git+https://github.com/vicr123/tttermwidget
md5sums = SKIP
pkgname = tttermwidget
diff --git a/PKGBUILD b/PKGBUILD
index 83e528acc608..5bcd324d7f31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,24 @@
-# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=tttermwidget
-pkgver=0.6.0
-pkgrel=2
-pkgdesc="A terminal widget for Qt"
+pkgver=1.0
+pkgrel=1
+pkgdesc="Terminal widget used by theTerminal"
arch=("i686" "x86_64")
url="https://github.com/vicr123/tttermwidget"
license=("GPL2")
-depends=("qt5-base" "libsm" "libxkbcommon-x11")
-makedepends=("cmake")
+depends=("qt5-base" "libsm" "libxkbcommon-x11" "libutf8proc" "the-libs")
source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/tttermwidget')
md5sums=("SKIP")
build() {
mkdir -p build
cd build
- cmake "$srcdir/$pkgname-$pkgver" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_DESIGNER_PLUGIN=0 \
- -DUSE_QT5=true
+ qmake $srcdir/$pkgname-$pkgver/tttermwidget.pro
make
}
package() {
cd build
- make DESTDIR="$pkgdir" install
+ make INSTALL_ROOT="$pkgdir" install
}