summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka2022-03-15 19:03:00 +0100
committerJakub Jirutka2022-03-15 19:26:07 +0100
commit04c36fee1bf0d8e63693c0c180e9fb727619e7b4 (patch)
tree71b659ac998c9eb89f2dad2e5897e8edaf6c8e1f
downloadaur-04c36fee1bf0d8e63693c0c180e9fb727619e7b4.tar.gz
Import package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b81be884148
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tty-copy
+ pkgdesc = Copy content to system clipboard via TTY and terminal using ANSI OSC52 sequence
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/jirutka/tty-copy
+ arch = any
+ license = MIT
+ makedepends = asciidoctor
+ source = tty-copy-0.2.0.tar.gz::https://github.com/jirutka/tty-copy/archive/v0.2.0.tar.gz
+ sha256sums = ff3326f1bbc4633a528009156d91a93fd7b649143894eb4e6afe09cdd06b8f90
+
+pkgname = tty-copy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4f234719049
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+
+pkgname=tty-copy
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Copy content to system clipboard via TTY and terminal using ANSI OSC52 sequence"
+arch=(any)
+url="https://github.com/jirutka/tty-copy"
+license=(MIT)
+makedepends=(asciidoctor)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jirutka/tty-copy/archive/v$pkgver.tar.gz")
+sha256sums=('ff3326f1bbc4633a528009156d91a93fd7b649143894eb4e6afe09cdd06b8f90')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ ./build/tty-copy -V
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}