summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Webb2017-02-10 10:08:19 -0800
committerTristan Webb2017-02-10 10:08:19 -0800
commit35931caac5c4c09ee10eb1371ffa7a68fc368792 (patch)
treee68c2b4c75b5139834044df930d4634abb94d232
downloadaur-35931caac5c4c09ee10eb1371ffa7a68fc368792.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1686d13fd8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ttyd-git
+ pkgdesc = Share your terminal over the web
+ pkgver = r1.2.2_3b58edb
+ pkgrel = 1
+ url = https://github.com/tsl0922/ttyd.git
+ arch = any
+ license = MIT
+ depends = libwebsockets-git
+ source = git+https://github.com/tsl0922/ttyd.git
+ sha256sums = SKIP
+
+pkgname = ttyd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0368d9721df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tristan Webb <olafthefrog@gmail.com>
+
+pkgname=ttyd-git
+_gitname=ttyd
+pkgver=r1.2.2_3b58edb
+pkgrel=1
+pkgdesc="Share your terminal over the web"
+arch=('any')
+url="https://github.com/tsl0922/ttyd.git"
+license=('MIT')
+builddepends=('cmake' 'base-devel')
+depends=('libwebsockets-git')
+source=(
+ "git+https://github.com/tsl0922/ttyd.git"
+ )
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/$_gitname && mkdir build
+ cd build
+ pwd
+ cmake ..
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname/build
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: