summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Houghton2018-08-29 13:30:41 -0400
committerJames Houghton2018-08-29 13:46:51 -0400
commit5620dd91623c5d3f864c7fa9d5d511ee0c2d3cd3 (patch)
tree2020b1ba0c27cefe1e9f58f42084720c45fbdf74
downloadaur-5620dd91623c5d3f864c7fa9d5d511ee0c2d3cd3.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9207504dd41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttydisp-git
+ pkgdesc = Play video in the terminal
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/jamesthoughton/ttydisp
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = ffmpeg
+ source = git+https://github.com/jamesthoughton/ttydisp
+ sha256sums = SKIP
+
+pkgname = ttydisp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0a6b2db612e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=ttydisp-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Play video in the terminal"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('ffmpeg')
+makedepends=('cmake' 'git')
+source=("git+https://github.com/jamesthoughton/ttydisp")
+url='https://github.com/jamesthoughton/ttydisp'
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}