summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian2018-12-15 02:37:50 +0100
committerAlexander Sulfrian2018-12-15 02:42:00 +0100
commit4cab7726567f26dfe60a1289172868e5da8c2b4c (patch)
tree1d32bd9d49b6b8a33367a475b2fae8bfb3ec52d2
downloadaur-ttyebus-dkms.tar.gz
Initial commit
This is the initial packageing of v1.5.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--dkms.conf7
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5d3d395cb58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttyebus-dkms
+ pkgdesc = Real time linux kernel module for the ebusd using the PL011 UART on a Rasperry Pi
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/eBUS/ttyebus
+ arch = any
+ license = GPL3
+ depends = dkms
+ conflicts = ttyebus
+ source = ttyebus::git+https://github.com/eBUS/ttyebus.git#commit=b39d79d8ae8512adefd73d7ea4b296e59769e7d5
+ source = dkms.conf
+ sha256sums = SKIP
+ sha256sums = 09fd52fecc4ed818560b1c3a1652dbd8f45badddb114d2c004314e4decf37664
+
+pkgname = ttyebus-dkms
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..585f50bc7480
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+ttyebus/
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c16698c7a060
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander Sulfrian <asulfrian@zedat.fu-berlin.de>
+
+_pkgbase=ttyebus
+pkgname=${_pkgbase}-dkms
+pkgver=1.5
+pkgrel=1
+pkgdesc="Real time linux kernel module for the ebusd using the PL011 UART on a Rasperry Pi"
+arch=('any')
+url="https://github.com/eBUS/ttyebus"
+license=('GPL3')
+depends=('dkms')
+conflicts=("${_pkgbase}")
+
+source=("ttyebus::git+https://github.com/eBUS/ttyebus.git#commit=b39d79d8ae8512adefd73d7ea4b296e59769e7d5"
+ "dkms.conf")
+sha256sums=("SKIP"
+ "09fd52fecc4ed818560b1c3a1652dbd8f45badddb114d2c004314e4decf37664")
+
+package() {
+ # Copy dkms.conf
+ install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ # Copy sources (including Makefile)
+ cp -r ${_pkgbase}/* "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..2f923b0643ed
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="@_PKGBASE@"
+PACKAGE_VERSION="@PKGVER@"
+MAKE[0]="make -C ${kernel_source_dir} M=${dkms_tree}/${PACKAGE_NAME}/${PACKAGE_VERSION}/build"
+CLEAN="make -C ${kernel_source_dir} M=${dkms_tree}/${PACKAGE_NAME}/${PACKAGE_VERSION}/build clean"
+BUILT_MODULE_NAME[0]="@_PKGBASE@"
+DEST_MODULE_LOCATION[0]="/extra"
+AUTOINSTALL="yes"