summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-02-15 16:46:02 +0100
committerJulien Nicoulaud2019-02-15 16:46:02 +0100
commit04efb4182060dbbd29cfe9cad5932e276702c00a (patch)
tree4d1d73a4ddf3d8005b1f9fcb643a6f4a4f034a7a
downloadaur-04efb4182060dbbd29cfe9cad5932e276702c00a.tar.gz
1.1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD26
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f4518b11c46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttyplot
+ pkgdesc = A realtime plotting utility for terminal with data input from stdin
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/tenox7/ttyplot
+ arch = x86_64
+ license = custom:The Unlicense
+ makedepends = make
+ makedepends = gcc
+ depends = ncurses
+ provides = ttyplot
+ conflicts = ttyplot-git
+ source = https://github.com/tenox7/ttyplot/archive/1.1.tar.gz
+ sha256sums = 56c4c9343d5da99a23e020e8c37f7f02178cd370983d602cd146f2bb67b0a155
+
+pkgname = ttyplot
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eab14e54627
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.xz
+/*.zst
+/*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d70baab4f5d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+
+pkgname=ttyplot
+pkgver=1.1
+pkgrel=1
+pkgdesc='A realtime plotting utility for terminal with data input from stdin'
+arch=('x86_64')
+url='https://github.com/tenox7/ttyplot'
+license=('custom:The Unlicense')
+depends=('ncurses')
+makedepends=('make' 'gcc')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://github.com/tenox7/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('56c4c9343d5da99a23e020e8c37f7f02178cd370983d602cd146f2bb67b0a155')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}
+