summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-04-11 23:50:43 +0300
committerAdrian Perez de Castro2021-04-11 23:50:43 +0300
commit0aa815bdd7637c138f072301bb62d6189c8b05a1 (patch)
treea0b4b85f14cebc638749e9734411906f68f06921
parent927e82688fb6043742e025e848afaaa65ceafc79 (diff)
downloadaur-0aa815bdd7637c138f072301bb62d6189c8b05a1.tar.gz
Also install license and README
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD21
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01e03f4b7d8a..2fe01007d9d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ttyplot
pkgdesc = A realtime plotting utility for terminal with data input from stdin
pkgver = 1.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tenox7/ttyplot
arch = x86_64
license = custom:The Unlicense
@@ -10,7 +10,7 @@ pkgbase = ttyplot
depends = ncurses
provides = ttyplot
conflicts = ttyplot-git
- source = https://github.com/tenox7/ttyplot/archive/1.4.tar.gz
+ source = ttyplot-1.4.tar.gz::https://github.com/tenox7/ttyplot/archive/1.4.tar.gz
sha256sums = 11974754981406d19cfa16865b59770faaf3ade8d909d9a0134dc56e00d29bd4
pkgname = ttyplot
diff --git a/.gitignore b/.gitignore
index 8eab14e54627..218620e2fb38 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
-/pkg/
-/src/
-/*.tar.gz
-/*.xz
-/*.zst
-/*.swp
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 9a683ac8f71c..3ad5670e2815 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=ttyplot
pkgver=1.4
-pkgrel=1
+pkgrel=2
pkgdesc='A realtime plotting utility for terminal with data input from stdin'
-arch=('x86_64')
-url='https://github.com/tenox7/ttyplot'
+arch=(x86_64)
+url=https://github.com/tenox7/ttyplot
license=('custom:The Unlicense')
-depends=('ncurses')
-makedepends=('make' 'gcc')
+depends=(ncurses)
+makedepends=(make gcc)
provides=("${pkgname}")
conflicts=("${pkgname}-git")
-source=("https://github.com/tenox7/${pkgname}/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tenox7/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('11974754981406d19cfa16865b59770faaf3ade8d909d9a0134dc56e00d29bd4')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
}